YEP ATB not working

KrimsonKatt

Pyromancer
Veteran
Joined
Nov 12, 2016
Messages
100
Reaction score
39
First Language
English
Primarily Uses
RMMV
Okay, I know what you're going to say. "But KrimsonKatt! Isn't YEP ATB is no longer supported! Of course it doesn't work!" I know that. However, there aren't that many options for ATB systems in MV, and I have continued to use Yanfly's ATB many times in many games, and it has always worked despite it being "no longer supported." Also of note is that I did change the "battle system" in YEP Battle Engine Core to ATB and it still doesn't work. It might be a problem with the plugin compatibility, so here I will list the plugins I have installed. Here we go!

  • Community Basic
  • Alt Save Screen
  • Item Book
  • GALV Directional Movement
  • SRD Press Start
  • SRD Remove Faded Continue
  • YEP Core Engine
  • YEP Buff States Core
  • YEP Class Change Core
  • YEP Damage Core
  • YEP Element Core
  • YEP Equip Core
  • YEP Item Core
  • YEP Options Core
  • YEP Skill Core
  • YEP Status Menu Core
  • YEP Element Absorb
  • YEP Element Reflect
  • YEP Job Points
  • YEP Life Steal
  • YEP Multi Type Skills
  • YEP Party System
  • YEP Row Formation
  • YEP Skill Learn System
  • YEP Steal Snatch
  • YEP Battle Statistics
  • YEP New Game Plus
  • YEP Visual HP Gauge

Any help would be highly appreciated. Thanks!
 

marsatche

Strawbebby
Member
Joined
Jan 28, 2020
Messages
27
Reaction score
23
First Language
English
Primarily Uses
RMMV
Yeah, those seem out of order... kinda like finding a needle in the haystack tho. If reordering doesn't work, prolly try removing them one by one? ;7; especially if ya added new plugins that you never used in previous projects
 

KrimsonKatt

Pyromancer
Veteran
Joined
Nov 12, 2016
Messages
100
Reaction score
39
First Language
English
Primarily Uses
RMMV
Yeah, those seem out of order... kinda like finding a needle in the haystack tho. If reordering doesn't work, prolly try removing them one by one? ;7; especially if ya added new plugins that you never used in previous projects
I don't know what you mean by "out of order." I always put the yanfly plugins last and put the core plugins first for the yanfly stuff. Is there some order I need to follow? I don't understand. Please tell me what order I need to put them in please.
 

glaphen

Veteran
Veteran
Joined
Jan 13, 2019
Messages
326
Reaction score
120
First Language
English
Primarily Uses
RMMV
I don't know what you mean by "out of order." I always put the yanfly plugins last and put the core plugins first for the yanfly stuff. Is there some order I need to follow? I don't understand. Please tell me what order I need to put them in please.
This page is the order
Go down list 1 by 1 and if you use plugin put it there, top of your list should be Yanfly Core Engine, next core updates and desktop optimization if you use it, if you don't ignore it, go to next until you reach dragonbones at the end of page, then below those put the non-yanfly plugins.
 

marsatche

Strawbebby
Member
Joined
Jan 28, 2020
Messages
27
Reaction score
23
First Language
English
Primarily Uses
RMMV
I don't know what you mean by "out of order." I always put the yanfly plugins last and put the core plugins first for the yanfly stuff. Is there some order I need to follow? I don't understand. Please tell me what order I need to put them in please.
Try to follow the exact order from the wiki page first (skip the ones that you don't use.) See if there are any errors after that, or if the other plugins stop working because of it.

then below those put the non-yanfly plugins.
In the past, I had to place Hudell's Orange plugins somewhere above Yanfly. But in your case, SRD's ones in your list are less of a priority in the system, so you can place em last. I'd only worry about Galv's cus it might have to override something else in Yanfly's code
 

glaphen

Veteran
Veteran
Joined
Jan 13, 2019
Messages
326
Reaction score
120
First Language
English
Primarily Uses
RMMV
Try to follow the exact order from the wiki page first (skip the ones that you don't use.) See if there are any errors after that, or if the other plugins stop working because of it.


In the past, I had to place Hudell's Orange plugins somewhere above Yanfly. But in your case, SRD's ones in your list are less of a priority in the system, so you can place em last. I'd only worry about Galv's cus it might have to override something else in Yanfly's code
Priority is actually higher is less important, lower ones overwrite higher ones if they use the same calls, most order doesn't matter, so use yanfly as reference, his all at top, bottom for rest unless they error then try putting it on top of the bottom of yanfly, then inside yanfly, if not it's just completely incompatible.

I changed the order of the plugins. I put all of Yanfly's plugins before anything else, with the core plugins first, then the plugins in order from the list second, then the YEP_X plugins after that. Galv's plugin is just a super simple one that allows you to walk diagonaly on the overworld. I doubt it would mess up Yanfly's plugins too much, right?
I mean does it work? You should still put same as page, not just core core core, it would be yanfly core engine then all the ones below that in the "core plugins" section, then "battle plugins" section order, then "item plugins" order.
 

KrimsonKatt

Pyromancer
Veteran
Joined
Nov 12, 2016
Messages
100
Reaction score
39
First Language
English
Primarily Uses
RMMV
I changed the order of the plugins. I put all of Yanfly's plugins before anything else, with the core plugins first, then the plugins in order from the list second, then the YEP_X plugins after that. Galv's plugin is just a super simple one that allows you to walk diagonally on the overworld. I doubt it would mess up Yanfly's plugins too much, right?

Edit: Also there are no errors occurring whatsoever. When I enter a battle it uses the MV side view default battle system instead of the Yanfly ATB one. I still don't know what the problem is...
 

glaphen

Veteran
Veteran
Joined
Jan 13, 2019
Messages
326
Reaction score
120
First Language
English
Primarily Uses
RMMV
I changed the order of the plugins. I put all of Yanfly's plugins before anything else, with the core plugins first, then the plugins in order from the list second, then the YEP_X plugins after that. Galv's plugin is just a super simple one that allows you to walk diagonally on the overworld. I doubt it would mess up Yanfly's plugins too much, right?

Edit: Also there are no errors occurring whatsoever. When I enter a battle it uses the MV side view default battle system instead of the Yanfly ATB one. I still don't know what the problem is...
Are you using an old version of MV with new Yanfly ATB or new version with old Yanfly ATB?
 

KrimsonKatt

Pyromancer
Veteran
Joined
Nov 12, 2016
Messages
100
Reaction score
39
First Language
English
Primarily Uses
RMMV
I'm using MV version 1.6.2. Yanfly's plugin is at 1.28, and I can't download the latest version as all his plugins are now paid if version 1.28 isn't the latest.
 

glaphen

Veteran
Veteran
Joined
Jan 13, 2019
Messages
326
Reaction score
120
First Language
English
Primarily Uses
RMMV
I'm using MV version 1.6.2. Yanfly's plugin is at 1.28, and I can't download the latest version as all his plugins are now paid if version 1.28 isn't the latest.
How about battle engine core, is that at least 1.46, that is free, do you have ATB turned off in the option menu with yanfly option core? Try disabling all other plugins except battle engine core and ATB. Take screenshots of your plugin manager and ATB/battle engine core settings.
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
30,051
Reaction score
7,036
First Language
German
Primarily Uses
RMMV
I'm using MV version 1.6.2.
I'm not sure if you understood the question, because your answer can be read in two ways.

There are two different version numbers involved here, the editor version and the project version.
Even if your editor is 1.6.2 that does NOT mean that your project is the same, because project updates are always manual and never automatic.
And it is possible that you use an 1.6.2 editor with an 1.0.0 project...

The version number that is critical for the plugins is the project version, and to check that you need to go to your project folder, into the js folder and then use a text editor to open rpg_core.js
The version number is at the end of the title line, if there is no number then it's 1.0.0

As for the plugin order - yanfly's plugins have to be in exactly the order given on the website linked above.
The position of non-yanfly-plugins in comparison to that needs to be experimented, they may have to be above or below or even mixed in between. That is because as described above the order determines which functions are overwriting which others and where functions are added etc.
That can only be guessed and tested - if you have problems after all of this, please give us a current screenshot of what you have now in your plugin manager. Then we can help you check for known problems.
 

KrimsonKatt

Pyromancer
Veteran
Joined
Nov 12, 2016
Messages
100
Reaction score
39
First Language
English
Primarily Uses
RMMV
I just checked, my project is the same version as the editor. I can't really put the plugins in the "official" order because you need YEP_JobPoints to be above YEP_SkillLearnSystem to use JP in the skill learn menu but in the order YEP_JobPoints is below YRP_SkillLearnSystem so that's kind of a problem. I'll try to put the plugins in the recommended order and see how that works.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Profile Posts

The end is near. The end is near. The MV era will be passed and people will look the forum about new RPG maker all days. ;_;[Election day all over again] Let accept that you will probably not what you want completely.
C&C Remastered comes out tomorrow! Hyped! Already have it preinstalled on Steam.
Its ironic, how often a person can have something smart to say, when their arrogance is originating from an internal vacuum where emotional intelligence belongs.
Parallax mapping is time consuming...
Let's purchase th... WAIT! Just in time ehehehe.

Forum statistics

Threads
98,152
Messages
949,737
Members
129,438
Latest member
Tsuna976
Top