YEP Auto Passive State & Passive Auras Lag

Discussion in 'Javascript/Plugin Support' started by alcreator440, Nov 9, 2019.

  1. alcreator440

    alcreator440 Veteran Veteran

    Messages:
    210
    Likes Received:
    93
    First Language:
    English
    Primarily Uses:
    RMMV
    Has anyone encountered this problem and/or a fix to it? Yanfly said in his recent version(1.17) that he optimized it but I don't see how since the lag is just as bad as the previous version. I'd be willing to pay someone a commission to fix this issue if they can.
     
    #1
  2. glaphen

    glaphen Villager Member

    Messages:
    6
    Likes Received:
    4
    First Language:
    English
    Primarily Uses:
    RMMV
    I was having massive lag from like 150 mostly empty states in tests, a few days ago I managed to solve it by removing everything from YEP_BattleStatusWindow and leaving only left right skip turn function, now I added more characters with 200 states with no lag, could probably fix it by just removing the icon related stuff from that plugin or not using it.
     
    #2
    alcreator440 likes this.
  3. alcreator440

    alcreator440 Veteran Veteran

    Messages:
    210
    Likes Received:
    93
    First Language:
    English
    Primarily Uses:
    RMMV
    Thanks for the advice but I'm still having issues with it. It's especially bad whenever my characters attack or deal damage and it's only multiplied when more characters are present in battle. (I am using YEP Buffs & States plugin if that helps.)
     
    #3
  4. glaphen

    glaphen Villager Member

    Messages:
    6
    Likes Received:
    4
    First Language:
    English
    Primarily Uses:
    RMMV
    I tried adding passive auras and made 2 auras that made a param buff each and it did lag badly on top of the 200, probably just that plugin.
     
    #4
  5. alcreator440

    alcreator440 Veteran Veteran

    Messages:
    210
    Likes Received:
    93
    First Language:
    English
    Primarily Uses:
    RMMV
    I think it helped a little but overeall I'm still experiencing some pretty rough lag. Thanks for the help though.
     
    #5
  6. glaphen

    glaphen Villager Member

    Messages:
    6
    Likes Received:
    4
    First Language:
    English
    Primarily Uses:
    RMMV
    I downloaded your demo and put it in the editor, I went to Gethal Labyrinth I, changed party limit to 8, added actors 1~8 and made them level 99, made an event that gave states 4~6, 37~43, 12~16, 20,24,27,30 and changed blind to +hit rate and all to no removal timing. the only lag I had was selecting a target which lowered frames down to 4 from doing nothing, around 30 from instant accepting, I disabled MOG_CursorBorder,MenuBorder and YEP_BattleSelectCursor, helped slightly, disabling X_SelectionControl removed it entirely, but I also use that with no lag so not sure why and I use slightly more plugins, attacking wise it was slightly less small frame drops, then I added all those states to actor global in passivestates and the lag actually decreased and the SelectionControl issue disappeared, as long as the other 3 were disabled but still lagged badly with those 3 on. So that was 256 states on just actors with the ones you already had set, more than my tests and I saw no real lag, hardware wise I only have a 2500k overclocked. If you are lagging still maybe check newly added plugins since demo or specific custom states.
     
    #6
    alcreator440 likes this.
  7. alcreator440

    alcreator440 Veteran Veteran

    Messages:
    210
    Likes Received:
    93
    First Language:
    English
    Primarily Uses:
    RMMV
    Oh wow I never thought anyone would actually download the current demo and try to reproduce this. I guess I should have stated that I'm using version 1.6.1 and the version of the old demo is like 1.5.2 or something. I've removed/updated/added a lot of plugins since then so it's not the same. Although I think the problem existed in the previous version as well but I'm not sure to what degree. I do feel it's worse in the current version I have(which I haven't released to anyone yet) and the game overall runs better besides this issue. Also giving the characters perfect hitrate will bypass the lag issue in the version you downloaded because you're bypassing the code the game needs to read for the player's inputs in the skills notetag. It's best to change the hitrate to what it was before and try to hit the enemies manually to reproduce the lag(and try to go for crits if you can since the lag was always worse when I critically hit the enemy).
     
    #7
  8. glaphen

    glaphen Villager Member

    Messages:
    6
    Likes Received:
    4
    First Language:
    English
    Primarily Uses:
    RMMV
    I removed states or changed them that were interfering with attacks, let the story switches and items trigger, replaced those removed states with more small ones, but couldn't really see any lag sparring with the first zone NPC, but here's the data file of what I was testing.
    https://files.catbox.moe/zwblr7.zip
     
    #8
  9. alcreator440

    alcreator440 Veteran Veteran

    Messages:
    210
    Likes Received:
    93
    First Language:
    English
    Primarily Uses:
    RMMV
    Okay here is a link to my actual current game project:

    Try opening up save file 10 and run around until you enter a battle. It has four characters with a lot of abilities equipped and the worst lag I've experienced so far. You should notice a lot of lag whenever you hit the enemies, especially with crits. Note if you see an enemy called Landeater just run away, it will waste your time. If you don't experience much lag then at least I'll know that it's probably just my anemic rig and I can relax a little. And thanks again for going out of your way to try and help me with this.
     
    Last edited: Nov 13, 2019
    #9
  10. glaphen

    glaphen Villager Member

    Messages:
    6
    Likes Received:
    4
    First Language:
    English
    Primarily Uses:
    RMMV
    Not really getting much lag, even on crits you get an instant of 40~ FPS but still smooth enough to ignore, using i5-2500k overclocked to 4ghz and RX 570 GPU,
     
    #10
    alcreator440 likes this.
  11. alcreator440

    alcreator440 Veteran Veteran

    Messages:
    210
    Likes Received:
    93
    First Language:
    English
    Primarily Uses:
    RMMV
    Then it's just my lousy rig lmao! Thanks a lot man this helped a lot. I'm taking that link down since I don't want too many people snooping through my project before the big update. I guess I just have to warn people with sorry rigs to expect lag. If anyone has any kind of scripting knowledge to alleviate the lag for slower systems then that would be very much appreciated.
     
    #11

Share This Page