YEP Equip Core Issues/Help

Discussion in 'Javascript/Plugin Support' started by Rob64_IV, Jun 1, 2018.

  1. Rob64_IV

    Rob64_IV Villager Member

    Messages:
    7
    Likes Received:
    6
    First Language:
    English
    Primarily Uses:
    RMMV
    I'm having issues getting Equip Core to function properly. I want to have a weapon do damage based on a character's base attack and level plus the weapon's base attack. Something like this:

    Code:
    (a.atk * 0.10) + a.level()
    But every time I go to view it ingame through the equip menu, it crashes and brings up the console saying "CUSTOM PARAMETER ERROR". Am I missing something?
     
    #1
    Sauteed_Onion likes this.
  2. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,239
    Likes Received:
    793
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    Please press F8 when the error shows up and provide a screenshot of the full error message.

    Edit:
    Your error is likely because "level" isn't a normal function, it's a getter, so it doesn't need to be called with parenthesis.
    Code:
    (a.atk * 0.10) + a.level
    
     
    Last edited: Jun 1, 2018
    #2
    Sauteed_Onion likes this.
  3. Rob64_IV

    Rob64_IV Villager Member

    Messages:
    7
    Likes Received:
    6
    First Language:
    English
    Primarily Uses:
    RMMV
    Yeah, I figured out that the way I was doing it was completely wrong but now I got it to work. Thanks though! :biggrin:
     
    #3

Share This Page