Yep EventCopier and Enigma Virtual Box "Script Error"

Discussion in 'Javascript/Plugin Support' started by Eliaquim, Jul 14, 2019.

Thread Status:
Not open for further replies.
    Tags:
  1. Eliaquim

    Eliaquim Raze: The Rakuen Zero's Guardian! Veteran

    Messages:
    742
    Likes Received:
    262
    Location:
    Brazil - Rio de Janeiro
    First Language:
    Portuguese - Br
    Primarily Uses:
    RMMV
    Hi people!

    I recently made a deployment to test my game.
    And sometimes, I get an error, sometimes, don't(Tested in two pcs. Both with Windows 10 Pro x64).

    Before I put the prints of the error, there are things you should know:

    1 - Rm Mv 1.6.2 - No change in the core plugins or package.json.

    2 - I upgrade the version of nwjs and chromium(nwjs-sdk-v0.39.2-win-x64) in the playtest and after the deployment. I change that following this thread.

    3 - I made a single executable file using Enigma Virtual Box.

    The error is related to something with Yep_EventCopier and Enigma Virtual Box.
    When I deploy the project, it works ok. But as soon as I use the Enigma Virtual Box to make one single executable, the error appears.

    So if someone knows a way to work around a solution for this, I will be happy...
    Maybe a different way to Yanfly Event Copier to read the Map data?


    This is the errors:
    [​IMG] [​IMG] [​IMG] [​IMG]

    YEP_EventCopier.js
     
    Last edited: Jul 17, 2019
    #1
  2. Poryg

    Poryg Dark Lord of the Castle of Javascreeps Veteran

    Messages:
    3,934
    Likes Received:
    9,942
    Location:
    Czech Republic
    First Language:
    Czech
    Primarily Uses:
    RMMV
    Apparently there is something wrong with the JSON map files you are loading. Both errors come from unsuccessful JSON.parse after a JSON of a map loads. It might be related to the Enigma virtual box wrapper, but cannot say for sure.
     
    #2
    Eliaquim likes this.
  3. Andar

    Andar Veteran Veteran

    Messages:
    28,448
    Likes Received:
    6,493
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    The event copier plugin is written to open other map files and copy events from there. And it appears as if some of those events from other maps are either stored or loaded wrong.

    So either some of your mapfiles are damaged (stored wrong), or something interferes with loading of them - and that can only be an incompatible other plugin messing up the load function because it didn't expect a plugin to load a mapfile that is not currently used.

    And please do NOT place plugin code here, but give weblinks to the plugins original website. That has a lot of reasons from licensing (a lot of plugin writers forbid reposts) to getting the latest versions to getting the additional manual instructions posted on those websites and more.
     
    #3
    Eliaquim likes this.
  4. Eliaquim

    Eliaquim Raze: The Rakuen Zero's Guardian! Veteran

    Messages:
    742
    Likes Received:
    262
    Location:
    Brazil - Rio de Janeiro
    First Language:
    Portuguese - Br
    Primarily Uses:
    RMMV
    Thanks guys! I will try to look at it right now!

    [EDIT]
    Well i tested here, and without enigma virtualbox the game don't show the error. With enigma virtual box it shows.

    Also I have opened the console, and without EVB it's ok.
    But, with EVB, even if the game runs(ocasionaly) the error is showing on the console.

    I also tried to change the map used by event copier and put another events in there. But the error persists.

    Maybe i will try another event copier, or simply will copy and paste the events around the map.

    Thanks!
     
    Last edited: Jul 15, 2019
    #4
  5. Wavelength

    Wavelength Pre-Merge Boot Moderator

    Messages:
    4,391
    Likes Received:
    3,665
    Location:
    Florida, USA
    First Language:
    English
    Primarily Uses:
    RMVXA

    I've moved this thread to Javascript/Plugin Support. Please be sure to post your threads in the correct forum next time. Thank you.


    Please go ahead and update your initial post (click Edit and then go to "Advanced" editing if you need to change add/change things outside the message body) to include the new info you found about the incompatibility between Yanfly's Event Copier plugin and EVB. Hopefully someone can help you figure it out here, since @Yanfly doesn't seem to accept bug reports from non-patrons due to his heavy workload.

    Admittedly this was a tough call between JS/Plugin Requests and Learning JS, as the people frequenting the latter forum might also be able to help you with their technical expertise. If you want a move over to Learning JS instead, just re-report your post and we'll move it again for you. If a week or two pass and no solution has been figured out, and you want to make a direct request in Plugin Requests for a compatibility patch, you may do so.

    I know this kind of outside-the-code-box technical issue can be frustrating. Good luck getting it resolved! :)
     
    #5
    Eliaquim likes this.
  6. Eliaquim

    Eliaquim Raze: The Rakuen Zero's Guardian! Veteran

    Messages:
    742
    Likes Received:
    262
    Location:
    Brazil - Rio de Janeiro
    First Language:
    Portuguese - Br
    Primarily Uses:
    RMMV
    Hi there!
    I happened to find this Triacontane plugin "TemplateEvent.js" that works perfectly using the Enigma Virtual Box.
    If someone comes across the same problem...
     
    #6
  7. bgillisp

    bgillisp Global Moderators Global Mod

    Messages:
    12,124
    Likes Received:
    12,306
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMVXA

    This thread is being closed, due to being solved. If for some reason you would like this thread re-opened, please report this post and leave a message why. Thank you.

     
    #7
Thread Status:
Not open for further replies.

Share This Page