YEP sideview battler version compatiability issue.

Discussion in 'Javascript/Plugin Support' started by Skurge, Oct 3, 2019.

  1. Skurge

    Skurge " (GASP) What's going on!? " Veteran

    Messages:
    1,049
    Likes Received:
    205
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    N/A
    For reasons unknown this plugin doesn't seem to want to work with versions higher than v1.5.2 and is making unstable compatibility issues such as images randomly being unable to locate within there own folders, sometimes frames not displaying properly and moving towards the right side of the screen instead of looping the animations in place. Sometimes even crashing before even booting up.

    I've been extensively reading into the plugin help section and understand now how to effectively use it- but I cannot proceed to get any results due to this annoying comparability issue. Now I've been pretty absent from the RPG maker community for a while but I'm back to make some progress and to my knowledge yanfly is no longer providing fixes for older plugins if I am not mistaken.

    Can I have some assistance with this plugin because I lack the ability to understand how to script.
    Download of the plugin was directed to me via this link:
     
    #1
  2. Andar

    Andar Veteran Veteran

    Messages:
    28,615
    Likes Received:
    6,568
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    it should work with 1.6.2 as far as I know - perhaps something else is adding to the compatibility problems, can you show us a screenshot of your plugin manager with all your plugins and their order/versions?
     
    #2
  3. Skurge

    Skurge " (GASP) What's going on!? " Veteran

    Messages:
    1,049
    Likes Received:
    205
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    N/A
    Certainly, here is the list of my plugins. I hope it isn't too staggering to look at theres quite a few.

    listo.png
     
    #3
  4. Skurge

    Skurge " (GASP) What's going on!? " Veteran

    Messages:
    1,049
    Likes Received:
    205
    Location:
    Australia
    First Language:
    English
    Primarily Uses:
    N/A
    Made a backup and updated the program to the latest version, still getting the same results however;
    Untitledwat.png

    For this enemy I am using this sheet and the following note tags.

    Code:
    <Turn Order Icon: 369>
    <Turn Order Border Color: 18>
    <Turn Order Background Color: 19>
    
    <Sideview Battler: SV_VoltorianMAC>
    
    <Sideview Battler Size: 69, 69>
    
    <Sideview Battler Motion>
    Name: Walk
    Index: 0
    Loop
    Frames: 5
    Speed: 10
    </Sideview Battler Motion>
    
    <Sideview Battler Motion>
    Name: Damage
    Index: 1
    Frames: 12
    Speed: 3
    </Sideview Battler Motion>
    
    <Sideview Battler Motion>
    Name: Skill
    Index: 2
    Frames: 10
    Speed: 5
    </Sideview Battler Motion>
    
    <Sideview Battler Motion>
    Name: Dying
    Index: 3
    Frames: 12
    Loop
    Speed: 10
    </Sideview Battler Motion>
    
    <Sideview Battler Motion>
    Name: Dead
    Index: 5
    Frames: 11
    Speed: 6
    </Sideview Battler Motion>
    SV_VoltorianMAC.png

    Basically I'm using the same note tags as a user who successfully has this program working in version 1.5.1 except I have changed the frame size to 69x69, I have double checked the dimensions of my sheet prior using it and it's 69x69 every row. It's hard to even workout why it's using the wrong frames and in some cases using 3 rows of frames like the image above.
     
    #4

Share This Page