Status
Not open for further replies.

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,781
Reaction score
2,710
@Yanfly There seems to be a little bug in the executeHpDamage function of your Party Limit Gauge Plugin



Game_Action.prototype.executeHpDamage = function(target, value) {
if (value > 0) {
var user = this.subject(); // <-- here. you can't use "user" in the formula for healing this way
target.friendsUnit().processPartyLimitGaugeEval(Yanfly.Param.PLGTakeHpDmg,
user, target, this.item(), value);
user.friendsUnit().processPartyLimitGaugeEval(Yanfly.Param.PLGDealHpDmg,
user, target, this.item(), value);
} else {
target.friendsUnit().processPartyLimitGaugeEval(Yanfly.Param.PLGHealHpDmg,
user, target, this.item(), value);
}
Yanfly.PLG.Game_Action_executeHpDamage.call(this, target, value);
};



Thanks, I'll get that fixed.
 

Genesis22

Hope in my road, Victory is my destiny
Member
Joined
Nov 16, 2014
Messages
5
Reaction score
0
First Language
Spanish
Primarily Uses
Hi all,
I have a small problem and I do not know what I'm doing wrong.
It started happening when I copied the ' Js ' folder of the last sample project.
The problem is that when I press the ' C ' key to jump ( pluging Smartjump and common buttons) gives me this error.
I would be very grateful if someone could help me. I took all afternoon trying to find out what happens unsuccessful.





Screenshot_1.jpg


PD: yanfly your work is more than awesome, no words to describe. thanks so much.
 

Assjacket

Warper
Member
Joined
Nov 25, 2013
Messages
4
Reaction score
0
First Language
English
Primarily Uses
I've got a small bug to report. Following procedure:

Plugin Name: Battle Status Window

Error Message: N/A

How to Replicate Bug: With your ATB battle system installed, initiate or test combat with the Battle Status Window plugin active and animations on. The combat must be set to frontview. All enemy attacks, skill animations, damage displays, and healing displays targetting allies will show up varying distances to the left of their actual portrait (and in some cases over the wrong portrait as a result). This occurs on all resolutions. It appears to be due to the fact that the party status window does not re-center after entering commands during ATB combat as it does in the default battle system, causing a misalignment.

Other: A screenshot has been attached for the sake of convenience. Keep up the great work, Yanfly!

cap.png
 

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,781
Reaction score
2,710
Hi all,
I have a small problem and I do not know what I'm doing wrong.
It started happening when I copied the ' Js ' folder of the last sample project.
The problem is that when I press the ' C ' key to jump ( pluging Smartjump and common buttons) gives me this error.
I would be very grateful if someone could help me. I took all afternoon trying to find out what happens unsuccessful.





View attachment 32014


PD: yanfly your work is more than awesome, no words to describe. thanks so much.



Did you copy the whole JS folder or just the JS/Plugins? If you copied the whole JS folder, you may have overwritten some plugin settings of your previous project. D: That's what's causing the error I'm guessing.

I've got a small bug to report. Following procedure:

Plugin Name: Battle Status Window

Error Message: N/A

How to Replicate Bug: With your ATB battle system installed, initiate or test combat with the Battle Status Window plugin active and animations on. The combat must be set to frontview. All enemy attacks, skill animations, damage displays, and healing displays targetting allies will show up varying distances to the left of their actual portrait (and in some cases over the wrong portrait as a result). This occurs on all resolutions. It appears to be due to the fact that the party status window does not re-center after entering commands during ATB combat as it does in the default battle system, causing a misalignment.

Other: A screenshot has been attached for the sake of convenience. Keep up the great work, Yanfly!


View attachment 32025



Go to the installed Battle Status Window and adjust the X Offset.
 

Hyakurai

Villager
Member
Joined
Jan 12, 2016
Messages
6
Reaction score
1
First Language
Portuguese
Dear yanfly, first of all i want to really really really thank you from my heart for your amazing, awesome, lovely and powerful plugins <3


second, i  want to make a question: is there any chances for something like an action sequence pack 4 or something, focused on animation effects? that would be amazing!


now the third and sad thing, i want to report a bug (or 2)


first bug is just a error i noticed today when i downloaded the last version of the plugins: battle system ctb is listed as 1.10a when the version is 1.11, this will probably be fixed by the time you see this, but it's ok. second is really a bug:


Plugin Name: Battle System CTB (Version 1.11) or Battle Engine Core (Version 1.32b) or Buffs States Core (Version 1.06)


Bug: There is a bug on some of those plugins. i'm not really sure wich one (but it's probably on BattleSysCTB ) so i'll detail how it's bugging:


first of all i used this skill:


<instant cast>


<setup action>


</setup action>


<target action>


action effect: user


</target action>


it's just a setup skill for the buff (for test purposes, this buff is simple):


<toggleable state>


<CTB Turn: +100%>


The idea: A buff that "stop" the time for everyone (except the user), so the user could use "endless" turns to atack. I'm also using Hime pluggin toggleable states to make this state toggleable, so the user may remove the state at any time.


The skill: Works fine if you have only this character in the party... however.


The problem: With other party members, after the skill use (the setup skill with instant cast), the user will be able to atack once, then the other party members will be able to atack, after the party members turns he will be able to attack "endlessly" untill the user toggles off the effect. If i remove the instant cast, he  will not be abble to attack since it will skip the turn. Also if there is no instant cast, if you toggle off the skill he will lose one turn as well. removing toggleable state also changes nothing, so i think there is no problem with those pluggins, the problem seems to be with ctb system and the buff (CTB Turn: +100%) . i didn't tested on atb or dtb system but i did tried to make other skills with same "stop time" effect, all ended up the same: party members have 1 turn before the state takes the "CTB turn: +100%" effect, other buff effects works on all turns (hp regen, stats increase/decrease, etc.).


i'm really sorry but i don't have any video and didn't printed since it would not explain anything, really.


again, thanks a lot yanfly!
 

TheAlphaRune

Fledgling Indie Developer
Veteran
Joined
Oct 29, 2015
Messages
48
Reaction score
4
First Language
English
@Yanfly


Alright so I did what you said and no line appeared over the characters when I made them actors.  It seems now though that this is happening to the still enemies now too.  It's not even just the characters made with the generator now.  I don't know why that could be happening now...


It's strange, things only look right if I make a new project.  Even if I copy over all the plugins I have on the old project it doesn't mess up.  But when I start bringing over images somehow it happens...I just don't understand. 
 

ThomasHarris

Villager
Member
Joined
May 27, 2013
Messages
19
Reaction score
1
First Language
Spanish
Primarily Uses
Hi Yanfly,


I've been trying to look over all this topic but is kind of hard with 90 pages, I just applied your Skill Core plugin to a new project and enabled it, this makes any learned skills text dissappear, as I go to the Skills menu to see each character skill the area is just blank, I can see the descriptions but nothing else and the same happens when we are in battle, I don't know what might be causing it or why as I even verified all the settings.
 

Georg

That guy that tries to do some big RPG
Veteran
Joined
May 28, 2014
Messages
30
Reaction score
4
First Language
Spanish
Primarily Uses
RMMZ
Hi Yanfly.



Hey, I just got this error when I went attacked by a Slime!! What happen??



PD: Sorry if anything is bad writing. Recently I begin to try write by myself, and I don't have much confidence in my english writing skills.
 

Assjacket

Warper
Member
Joined
Nov 25, 2013
Messages
4
Reaction score
0
First Language
English
Primarily Uses
Go to the installed Battle Status Window and adjust the X Offset.


I tried adjusting the X offset prior to making the post, but the amount of offset for each battler appears to be different rather than a consistent number. In addition, it doesn't change the position of the damage/healing numbers at all.
 

guyhi

Villager
Member
Joined
Jan 7, 2016
Messages
13
Reaction score
1
First Language
English
Hey, Yanfly, I found out what caused the bug, and it's not an error on your part at all, so don't worry about it. I was using no default battleback before, so it used what was on the map, and the name box was still on the map, so it showed that.
 

Alistair

Treasure Hunter
Veteran
Joined
Jun 15, 2014
Messages
283
Reaction score
197
First Language
English
Primarily Uses
RMMV
Hi Yanfly.



Hey, I just got this error when I went attacked by a Slime!! What happen??



PD: Sorry if anything is bad writing. Recently I begin to try write by myself, and I don't have much confidence in my english writing skills.



You need to start a new game.
 

ufi24472

Veteran
Veteran
Joined
Feb 20, 2016
Messages
21
Reaction score
1
Primarily Uses
YEP.71 – Life Steal – RPG Maker MV


This plug-in, if it continues the game (loading archive), an error occurs.


Must create a new game, there is no way to solve this problem?


This plug-in requires the player must re-start the game, not a good feeling.


Thank you.


[IMG]http://i.imgur.com/pGBYc6P.png[/IMG]





01.png
 
Last edited by a moderator:

ufi24472

Veteran
Veteran
Joined
Feb 20, 2016
Messages
21
Reaction score
1
Primarily Uses
YEP.71 – Life Steal – RPG Maker MV


This plug-in, if it continues the game (loading archive), an error occurs.


Must create a new game, there is no way to solve this problem?


This plug-in requires the player must re-start the game, not a good feeling.


Thank you.
 

bgillisp

Global Moderators
Global Mod
Joined
Jul 2, 2014
Messages
14,338
Reaction score
15,504
First Language
English
Primarily Uses
RMVXA
YEP.71 – Life Steal – RPG Maker MV


This plug-in, if it continues the game (loading archive), an error occurs.


Must create a new game, there is no way to solve this problem?


This plug-in requires the player must re-start the game, not a good feeling.


Thank you.

Sorry, but all plug-ins usually require you to start a new game. This cannot be fixed (usually) as plug-ins introduce new variables that did not exist when the save game was made, so when they go to look for them and don't find them the program crashes.
 

ufi24472

Veteran
Veteran
Joined
Feb 20, 2016
Messages
21
Reaction score
1
Primarily Uses
很抱歉,但所有的插件通常需要你開始一個新遊戲。這不可能是固定的(通常)作為插件引入保存遊戲作出時並不存在,因此,當他們去尋找他們,並沒有發現他們的程序崩潰的新變量。

No way to solve it?


If want to update the game has been released, it will cause great distress.
 

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,781
Reaction score
2,710
Dear yanfly, first of all i want to really really really thank you from my heart for your amazing, awesome, lovely and powerful plugins <3


second, i  want to make a question: is there any chances for something like an action sequence pack 4 or something, focused on animation effects? that would be amazing!


now the third and sad thing, i want to report a bug (or 2)


first bug is just a error i noticed today when i downloaded the last version of the plugins: battle system ctb is listed as 1.10a when the version is 1.11, this will probably be fixed by the time you see this, but it's ok. second is really a bug:


Plugin Name: Battle System CTB (Version 1.11) or Battle Engine Core (Version 1.32b) or Buffs States Core (Version 1.06)


Bug: There is a bug on some of those plugins. i'm not really sure wich one (but it's probably on BattleSysCTB ) so i'll detail how it's bugging:


first of all i used this skill:


<instant cast>


<setup action>


</setup action>


<target action>


action effect: user


</target action>


it's just a setup skill for the buff (for test purposes, this buff is simple):


<toggleable state>


<CTB Turn: +100%>


The idea: A buff that "stop" the time for everyone (except the user), so the user could use "endless" turns to atack. I'm also using Hime pluggin toggleable states to make this state toggleable, so the user may remove the state at any time.


The skill: Works fine if you have only this character in the party... however.


The problem: With other party members, after the skill use (the setup skill with instant cast), the user will be able to atack once, then the other party members will be able to atack, after the party members turns he will be able to attack "endlessly" untill the user toggles off the effect. If i remove the instant cast, he  will not be abble to attack since it will skip the turn. Also if there is no instant cast, if you toggle off the skill he will lose one turn as well. removing toggleable state also changes nothing, so i think there is no problem with those pluggins, the problem seems to be with ctb system and the buff (CTB Turn: +100%) . i didn't tested on atb or dtb system but i did tried to make other skills with same "stop time" effect, all ended up the same: party members have 1 turn before the state takes the "CTB turn: +100%" effect, other buff effects works on all turns (hp regen, stats increase/decrease, etc.).


i'm really sorry but i don't have any video and didn't printed since it would not explain anything, really.


again, thanks a lot yanfly!



I'm unsure if I'll be releasing an Action Sequence Pack 4. If anything, I'll be releasing individual action sequences independently of each other.


As far as the skill is concerned, you've trying to do too many things at once and using too many workarounds at once. Not to mention Time Stop is one of the more difficult effects to achieve. I'm afraid I cannot help you here.
 

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,781
Reaction score
2,710
@Yanfly


Alright so I did what you said and no line appeared over the characters when I made them actors.  It seems now though that this is happening to the still enemies now too.  It's not even just the characters made with the generator now.  I don't know why that could be happening now...


It's strange, things only look right if I make a new project.  Even if I copy over all the plugins I have on the old project it doesn't mess up.  But when I start bringing over images somehow it happens...I just don't understand. 



Did you turn off all non-Yanfly plugins? Because from what I've tested, there is no bleeding occurring:


VrX6BOe.jpg



If it were my plugin's fault, then there would be a line at the top of that box of a different color since I'm using this spritesheet:


EISWukz.png



That said, I suggest you you align your spritesheets with the spritesheet I've shown above. If it doesn't line up properly, that's the fault of your spritesheet.

Hi Yanfly,


I've been trying to look over all this topic but is kind of hard with 90 pages, I just applied your Skill Core plugin to a new project and enabled it, this makes any learned skills text dissappear, as I go to the Skills menu to see each character skill the area is just blank, I can see the descriptions but nothing else and the same happens when we are in battle, I don't know what might be causing it or why as I even verified all the settings.



***Didn't update properly


When you updated the plugin, did you /open up/ the plugin within the Plugin Manager? 


You are getting the error because you updated the plugin and did not go into the plugin itself like the instructions here said: https://www.youtube.com/watch?v=vIwM2PnOr08


Why is this important? Because whenever new parameters are added to a plugin upon a new update, you have to enter the plugin in order for the Plugin Manager to add those new parameters into your game. Otherwise, you will get undefined errors and "random" crashes. Skipping that step is not optional and is very crucial to getting updated plugins to work.


---------

Hi Yanfly.



Hey, I just got this error when I went attacked by a Slime!! What happen??



PD: Sorry if anything is bad writing. Recently I begin to try write by myself, and I don't have much confidence in my english writing skills.
  • Previous Page
  • Next Page



YEP.71 – Life Steal – RPG Maker MV


This plug-in, if it continues the game (loading archive), an error occurs.


Must create a new game, there is no way to solve this problem?


This plug-in requires the player must re-start the game, not a good feeling.


Thank you.


pGBYc6P.png




  • Previous Page
  • Next Page



View attachment 32086



I've updated Life Steal so it wouldn't crash on saved games: http://yanfly.moe/plugins/en/YEP_LifeSteal.js


However, any changes made to items that a player already has in a save game made before the installation of the plugin will not have Life Steal properties. Your independent items do not have the new effects because you are using a saved game from a time where the plugin's effects did not exist. The plugin does not retroactively change independent items to fit the alterations of the base item. That's not how independent items work as they are their own item. However, newly generated items of that base item will have the new effects.

I tried adjusting the X offset prior to making the post, but the amount of offset for each battler appears to be different rather than a consistent number. In addition, it doesn't change the position of the damage/healing numbers at all.



I will suggest that you don't use the Battle Status Window plugin then since it's not doing what you want. Instead, you ought to make a plugin request here: http://forums.rpgmakerweb.com/index.php?/forum/136-js-plugin-requests/
 

Georg

That guy that tries to do some big RPG
Veteran
Joined
May 28, 2014
Messages
30
Reaction score
4
First Language
Spanish
Primarily Uses
RMMZ
Did you turn off all non-Yanfly plugins? Because from what I've tested, there is no bleeding occurring:





If it were my plugin's fault, then there would be a line at the top of that box of a different color since I'm using this spritesheet:





That said, I suggest you you align your spritesheets with the spritesheet I've shown above. If it doesn't line up properly, that's the fault of your spritesheet.


***Didn't update properly


When you updated the plugin, did you /open up/ the plugin within the Plugin Manager? 


You are getting the error because you updated the plugin and did not go into the plugin itself like the instructions here said: https://www.youtube.com/watch?v=vIwM2PnOr08


Why is this important? Because whenever new parameters are added to a plugin upon a new update, you have to enter the plugin in order for the Plugin Manager to add those new parameters into your game. Otherwise, you will get undefined errors and "random" crashes. Skipping that step is not optional and is very crucial to getting updated plugins to work.


---------


I've updated Life Steal so it wouldn't crash on saved games: http://yanfly.moe/plugins/en/YEP_LifeSteal.js


However, any changes made to items that a player already has in a save game made before the installation of the plugin will not have Life Steal properties. Your independent items do not have the new effects because you are using a saved game from a time where the plugin's effects did not exist. The plugin does not retroactively change independent items to fit the alterations of the base item. That's not how independent items work as they are their own item. However, newly generated items of that base item will have the new effects.


I will suggest that you don't use the Battle Status Window plugin then since it's not doing what you want. Instead, you ought to make a plugin request here: http://forums.rpgmakerweb.com/index.php?/forum/136-js-plugin-requests/

I see... Well, thanks for the help :) I going to update now.
 

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,781
Reaction score
2,710
Item Core >> Item Durability


Features and How to Use










Independent Weapons and Armors will now have a Durability value. Over the course of battle, equipment durability will drop based on actions performed, damage taken, and the like. When a piece of equipment’s durability value reaches 0, the piece of equipment will break. Durability can be repaired by items and increased by skills, too.


Plugin and Instructions: http://yanfly.moe/2016/02/20/yep-72-item-durability/
 
Status
Not open for further replies.

Latest Threads

Latest Profile Posts

Finally finished moving into a new place. I'm freakin' exhausted. 6 days of moving crap will do that to you. I am out of shape. Then again... multiple trips up 5 flights of stairs with boxes will wear you out...
✨NUMINA Big Update Release!! ✨
New relationship mechanics, improved translation & update on Part II release =>
How is it the final month of 2022 already? feel like we were still in January yesterday
Each story takes the point of view of each character. and I have 25 characters. meaning I have to learn more about cutscenes.
I'm weak at this
Screenshot (59).png
Bex
Editing POP Tileset DLCs to fit as many needed Tiles as possible on 1 outdoor and 1 indoor Tileset.
It is to practise and to get me easier started with prototyping some early Maps. Just started editing/rearranging the Tilesets.

Forum statistics

Threads
126,964
Messages
1,182,702
Members
166,810
Latest member
Derpsi
Top