Status
Not open for further replies.

Punyapon

Warper
Member
Joined
Apr 26, 2016
Messages
3
Reaction score
0
First Language
English
Primarily Uses
Hi Yanfly and all!


Thank you for making RPG maker better and better. Yanfly's scripts are really wonderful to all versions of RPG Makers.


Also the video tutorials and plugins descriptions/help are made for easy understanding, which is very professional.


Today, I have a glitch report. Very easy to recreate one.


I'm using the latest version (26/4/16) of Skill Learn System and Equip Battle Skills. The issue is when I use some skills that can use in menu (heal, etc.)


after I pressed back to the Skill Type list (Equip Skills, Magic,...,Learn Skills) The default of selected command is no longer the top (Equip Skills) but


it is always focused at Magic (skill type) instead. This result happens every time after using that magic once. (when try changing actor with W/Q at Skill Type menu)


It doesn't affect the game but it shouldn't happening, I guess.


**Updated** After trying to figure it out, even a new fresh project by MV 1.2.0 without any Yanfly's plugins, The focused skill type will be updated to the last used skill for each actor....by the way, it's inconvenience to directly go to equip battle skill equip command. Sorry for


the mistakes :\
 
Last edited by a moderator:

LolSheeps

Villager
Member
Joined
Aug 16, 2012
Messages
18
Reaction score
3
Primarily Uses
Your Equip Battle Skills plug in started removing my custom skill type names and simply named them "Skill". Any suggestions?
 

Yanfly

Developer
Joined
Mar 15, 2012
Messages
1,696
Reaction score
2,329
Is there a way to stop this or an option to turn this off? If not, will there be in the future?


I may change this in the future. For now, I won't be turning it off since it's based off of MV's default function to seek a random target if the desired target doesn't exist, which is intended behavior as to not waste actions.


---

Hi Yanfly! I just want to ask if you are planning to release a mac version of the Yanfly Icon Generator :) . Hope this dont sounds rude (my english is rusty) Thx for all the passion that you put in your work!


Not yet. My experience with Mac programming is minimal at best.


---

the icon generator keeps crashing on me, i find it most vexing, i eep nedding to save, which i wouldn't mind if it were not the fact that it freezes up every other minute.


Also yanfly not sure why but i can't move with your FPSsync option plugin, is that intentional?


The engine is RMMV's default engine. Do you experience lag with your MV games, too? Because otherwise, this shouldn't be happening. However, there is a large amount of resources being loaded at once, at which, if it exceeds your computer's memory, will cause it to crash.


As for the FPSSynch, straight from the FPS Synch plugin page:


WARNING: This plugin ABSOLUTELY REQUIRES that your project is using at least version 1.1.0 of the source code or you will NOT receive any keyboard or mouse inputs. You can download MV v1.1.0’s update here. If you’ve installed MV v1.1.0 and it still doesn’t work, it’s most likely because your project’s base source code is still in version 1.0.0. To check this, go to your project’s “js” folder and open up the rpg_x.js files. If you do NOT see “1.1.0” at the top, then you do not have the 1.1.0 version of the source code. At this point, create a new project with your installed MV v1.1.0, go to the new project’s “js” folder, copy all of the rpg_x.js files, and then copy them into your main project’s “js” folder. Save your project and then it should work after that. If moving over to version 1.1.0 is not an option for you, then you don’t need this plugin anyway as it is meant to disable Galenmereth’s fluid timestep problem which is only a problem with the version 1.1.0 update.


---

Is it intended that characters always start with enough EXP to reach level 2 right away when using Class Base Parameters to set the exp curve?


I'm using the formula:


<Custom Class Parameters>


exp = level * 5 + 15;


</Custom Class Parameters>


And my character always starts the game with 20 EXP.


This appears to be a visual issue. I'll have to see what's causing it.


---

Hi Yanfly. Excellent plugins! Encountering a problem though.


Plugin Name: YEP_X_Subclass


Error Message: Uncaught ReferenceError: Yes is not defined
rpg_managers.js:1722 TypeError: undefined is not a function
    at Game_Actor.isSublcassEarnJp (file:///C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_JobPoints.js:489:15)
    at Game_Actor.gainJp (file:///C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_JobPoints.js:482:52)
    at Game_Actor.levelUp (file:///C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_JobPoints.js:521:8)
    at Game_Actor.changeExp (file:///C:/Users/Michael/Documents/Games/Quest/js/rpg_objects.js:3870:14)
    at Game_Actor.changeLevel (file:///C:/Users/Michael/Documents/Games/Quest/js/rpg_objects.js:3933:10)
    at Game_Party.<anonymous> (file:///C:/Users/Michael/Documents/Games/Quest/js/rpg_objects.js:4868:19)
    at Array.forEach (native)
    at Game_Party.setupBattleTestMembers (file:///C:/Users/Michael/Documents/Games/Quest/js/rpg_objects.js:4865:30)
    at Game_Party.setupBattleTest (file:///C:/Users/Michael/Documents/Games/Quest/js/rpg_objects.js:4860:10)
    at Game_Party.setupBattleTest (file:///C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_SkillLearnSystem.js:627:43)


OR - (if attempting to use a skill)


Uncaught ReferenceError: Yes is not defined
rpg_managers.js:1722 TypeError: undefined is not a function
    at Game_Actor.isSublcassEarnJp (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_JobPoints.js:489)
    at Game_Actor.gainJp (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_JobPoints.js:482)
    at Game_Actor.Game_Battler.useItem (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_JobPoints.js:400)
    at Function.BattleManager.startAction (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_BattleEngineCore.js:1888)
    at Function.BattleManager.startCTBAction (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_X_BattleSysCTB.js:1106)
    at Function.BattleManager.selectNextCommand (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_X_BattleSysCTB.js:1006)
    at Scene_Battle.selectNextCommand (rpg_scenes.js:2295)
    at Scene_Battle.selectNextCommand (/C:/Users/Michael/Documents/Games/Quest/js/plugins/YEP_BattleEngineCore.js:4047)
    at Scene_Battle.onEnemyOk (rpg_scenes.js:2346)
    at Window_BattleEnemy.Window_Selectable.callHandler (rpg_windows.js:896)


How to Replicate Bug: This error only occurs when the Subclass plugin is active and at the start of battle. The only parameters changed are 'Subclass command' (named it Specialisation) and 'Show command' (false). I have attached an image of my actor notes incase the error is there. If the actor level is low, the battle will start but the error will occur when the first person (actor or enemy) uses a move other than Guard. Using a skill results in the second error message whilst using the attack function results in the first. Possibly having something to do with the animation (which are default). If I set the actor levels higher during the test, the battle will not start and instead I get the first error message straight away. This happens both in the Battle Test and Play Test.


Many thanks and hoping you can help!


View attachment 36955


1. Download all the newest updates of the plugin.
2. Create a new project. Do NOT just copy over your game project folders. This should be just a stock, empty, new RPG Maker MV project.
3. If the project's file size is above 200 MB, remove unnecessary audio and image files until you reach that size. Usehttp://forums.rpgmakerweb.com/index.php?/topic/47985-mvstripper-remove-unused-assets-from-your-mv-project/ if you need some help doing so.
4. Install -only- the affected plugins. If you're using non-YEP plugins, do NOT include them.
5. Do -NOT- rename the plugins' filenames. They cease to work if you do so.
6. Make sure they're in the right order listed on http://yanfly.moe/yep/
7. Recreate the error.
8. Archive the project with WinZip or WinRAR. Do not archive it multiple times. It does not compress it further.
9. Upload the project online (do -not- deploy it) to a website like MediaFire.com or Mega.co.nz or Dropbox. Please do not use a website that involves timers like 4shared, RapidShare, etc.
10. Post the link here and I'll take a look at it.


Thanks for helping!


---

Plugin Name: YEP_X_ExtMesPack1   -  Reported on page 141, haven't heard if it was an intended function of the plugin.


Plugin Name: YEP_X_AttachAugments


I am trying to add an augment to an item in an equipment slot via javascript in an event that runs to initialize my game.


I've narrowed down the error a bit, and it's easy to reproduce.


Here's some script from my parallel event from game start:


------------------------------


  $gameActors.actor(1).changeEquipById(3,136);// UFM Implant


  ItemManager.installAugmentToSlot($gameActors.actor(1).equips()[2], $dataItems[81], 0);


------------------------------


The Equipment is added to the slot as intended, but the attempt to install augment to it throws this error:  


----------


TypeError: Cannot set property '0' of undefined
    at Function.ItemManager.installAugmentToSlot (file:///F:/Kaos/Kaos/js/plugins/YEP_X_AttachAugments.js:718:37)
    at Game_Interpreter.eval (eval at <anonymous> (file:///F:/Kaos/Kaos/js/rpg_objects.js:10439:10), <anonymous>:4:13)
    at Game_Interpreter.command355 (file:///F:/Kaos/Kaos/js/rpg_objects.js:10439:5)
    at Game_Interpreter.executeCommand (file:///F:/Kaos/Kaos/js/rpg_objects.js:8897:34)
    at Game_Interpreter.update (file:///F:/Kaos/Kaos/js/rpg_objects.js:8805:19)
    at Game_Event.updateParallel (file:///F:/Kaos/Kaos/js/rpg_objects.js:8716:27)
    at Game_Event.update (file:///F:/Kaos/Kaos/js/rpg_objects.js:8708:10)
    at file:///F:/Kaos/Kaos/js/rpg_objects.js:6033:15
    at Array.forEach (native)
    at Game_Map.updateEvents (file:///F:/Kaos/Kaos/js/rpg_objects.js:6032:19)rpg_managers.js:1722 SceneManager.catchExceptionrpg_managers.js:1683 SceneManager.update


----------


I copied the ItemManager.installAugmentToSlot() function and removed it from the event.  Then I pasted it into the console at each point as I navigated the main menu, item scene, equipment category, and resting selection on the equipped item (but not selecting it yet, so I can't see the augment slots).  It always threw the same error.


Next, I selected the item so I could see the augment slots, then pasted the command in the console again.  It worked perfectly.


Is there a way to fix this so that I can add the augments to equipped items before accessing them from the equipment category in the item scene for the first time?  If not, could someone suggest how I could circumvent the issue?  I know how to call the item scene, but I haven't had to figure out how to force the selection into a category or select an item from one of the categories, or even exit the scene yet.  I'll start looking for the commands that let me do that if it's the only way.  Thank you!


I'm little more than a dabbler in programming, but I hope the information helps.


I'm afraid I can't help you with this as I'm only currently providing support for my own code and not code made by others, even if it's a snippet.


---

Hi Yanfly and all!


Thank you for making RPG maker better and better. Yanfly's scripts are really wonderful to all versions of RPG Makers.


Also the video tutorials and plugins descriptions/help are made for easy understanding, which is very professional.


Today, I have a glitch report. Very easy to recreate one.


I'm using the latest version (26/4/16) of Skill Learn System and Equip Battle Skills. The issue is when I use some skills that can use in menu (heal, etc.)


after I pressed back to the Skill Type list (Equip Skills, Magic,...,Learn Skills) The default of selected command is no longer the top (Equip Skills) but


it is always focused at Magic (skill type) instead. This result happens every time after using that magic once. (when try changing actor with W/Q at Skill Type menu)


It doesn't affect the game but it shouldn't happening, I guess.


When you healed even without the plugins installed, the command never returned to the top to begin with. It always stayed focus on the current selected skill type. I've done nothing to change the nature of this.


---

Your Equip Battle Skills plug in started removing my custom skill type names and simply named them "Skill". Any suggestions?


That's how the plugin works. ALL Skill Types are removed.
 
Last edited by a moderator:

darico06

Villager
Member
Joined
Apr 24, 2016
Messages
7
Reaction score
0
First Language
English
Primarily Uses
Hi Yanfly, thanks for the response.


In trying to recreate the issue on a new game I realised my mistake. I had put 'yes' instead of 'true' in one of the fields! Everything works now.


Sorry to have wasted your time!
 

Reaxus

Villager
Member
Joined
Dec 13, 2015
Messages
14
Reaction score
1
First Language
English
Hello Yanfly!
I've stumbled upon a problem using the passive states,


I'm using this code:


<Custom Passive Condition>
if ($gameParty.leader().actorId() == 3) {
condition = true;
} else {
condition = false;
}

</Custom Passive Condition>


but it gives me back "Cannot read property 'actorId' of undefined.



what im trying to get is that it checks if the leader is party member 3.
I tried 3 equals,
removing the '()s' (it'll run the game but the passive skill wont work)

the skill im trying to do is if party leader is actor = # , that person has a leader skill and would share it to others.
i got a work around with it using basetroopevent plugin u also made!
but im trying to make tons of leader skills which would fill it out and maybe have a delay on my game at the start of battle cause


it'll read tons of events.

hope you could help me out of this! Thanks again for giving us an awesome engine!

Have a great day.
 

Yanfly

Developer
Joined
Mar 15, 2012
Messages
1,696
Reaction score
2,329
I think you might've omitted my post.


Ah, looks like I did, my bad. ;A; For this, it falls in the exp formula given by Class Base Parameters. I'll see to getting it fixed by tonight.


---

Hello Yanfly!
I've stumbled upon a problem using the passive states,


I'm using this code:



<Custom Passive Condition>
if ($gameParty.leader().actorId() == 3) {
condition = true;
} else {
condition = false;
}

</Custom Passive Condition>


but it gives me back "Cannot read property 'actorId' of undefined.



what im trying to get is that it checks if the leader is party member 3.
I tried 3 equals,
removing the '()s' (it'll run the game but the passive skill wont work)

the skill im trying to do is if party leader is actor = # , that person has a leader skill and would share it to others.
i got a work around with it using basetroopevent plugin u also made!
but im trying to make tons of leader skills which would fill it out and maybe have a delay on my game at the start of battle cause


it'll read tons of events.

hope you could help me out of this! Thanks again for giving us an awesome engine!

Have a great day.


For this, I recommend you ask in the JS Support forum: http://forums.rpgmakerweb.com/index.php?/forum/128-javascriptplugin-support/


This thread is limited to only support for my own code, Lunatic Mode code will not be supported unless the code is provided by me through a Tips & Tricks video as per the first post of this thread:


NOTE: I'll only provide support for my own plugins and code that I, myself, have provided. This isn't because I disrespect other plugin makers or anything of the sort. If I did, I wouldn't go so far as to maximize compatibility with my plugins when possible. The reason behind is because of my lack of time, and I'd like to put my undivided attention to errors caused by my own plugins. That said, any modifications you've made to the plugins itself, any custom Lunatic Mode code you've made yourself that isn't provided by me, or problems with the source code will not be supported by me either.
 

Reaxus

Villager
Member
Joined
Dec 13, 2015
Messages
14
Reaction score
1
First Language
English
Ah i see! thanks for replying, Yanfly! :D
gonna try my luck on the link you gave me
 

Punyapon

Warper
Member
Joined
Apr 26, 2016
Messages
3
Reaction score
0
First Language
English
Primarily Uses
Thanks for replying, Yanfly.


Anyway, could someone show me how  to check user's state to let a skill becomes available?


SkillCore:


<Custom Requirement>


if ($gameParty.gold() > 1000) {


value = true;


} else {


value = false;


}


</Custom Requirement>


How to write the check user state js? if I want to check if user is in state id 5 for example.


Thanks alot!
 

Crimson Dragon Inc.

Crimson Dragon
Veteran
Joined
Aug 8, 2012
Messages
925
Reaction score
135
First Language
english
Primarily Uses
RMMV
about your class parameter plug in.....do the formulas work with plug ins that additional stats 


exsample:


HP = ((end*1.1)+(VIT*1.2)+(str*.75))*1.2
 

nerochepiace

Veteran
Veteran
Joined
Dec 1, 2015
Messages
48
Reaction score
2
First Language
italian
Primarily Uses
Plugin Name: Row Formation

Error Message: user is not defined

ReferenceError: user is not defined
at Game_Actor.eval (eval at (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1254:10), :1:5)
at Game_Actor.Game_Battler.userRowEval (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1254:5)
at Game_Action.applyUserItemRowEffect (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1357:39)
at Game_Action.apply (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1329:12)
at Function.BattleManager.invokeNormalAction (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/rpg_managers.js:2297:18)
at Function.BattleManager.invokeAction (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:1718:10)
at Function. (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:2307:14)
at Array.forEach (native)
at Function.BattleManager.actionActionEffect (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:2304:13)
at Function.BattleManager.processActionSequence (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:1917:19)rpg_managers.js:1722 SceneManager.catchException

How to Replicate Bug: use a skill with the tag //Custom User Row

Other: I must report a probable bug, but it's not my catch!
The original one is http://forums.rpgmakerweb.com/index.php?/topic/60893-yanfly-row-formation-lunatic-help/&_fromLogin=1#replyForm
I was trying to do something similar and found that the call to user give me a error.
I even tried to use the code provided in the plugin, but error pop up without mercy.
 

Yanfly

Developer
Joined
Mar 15, 2012
Messages
1,696
Reaction score
2,329
Thanks for replying, Yanfly.


Anyway, could someone show me how  to check user's state to let a skill becomes available?


SkillCore:


<Custom Requirement>


if ($gameParty.gold() > 1000) {


value = true;


} else {


value = false;


}


</Custom Requirement>


How to write the check user state js? if I want to check if user is in state id 5 for example.


Thanks alot!


From the first post: 


NOTE: I'll only provide support for my own plugins and code that I, myself, have provided. This isn't because I disrespect other plugin makers or anything of the sort. If I did, I wouldn't go so far as to maximize compatibility with my plugins when possible. The reason behind is because of my lack of time, and I'd like to put my undivided attention to errors caused by my own plugins. That said, any modifications you've made to the plugins itself, any custom Lunatic Mode code you've made yourself that isn't provided by me, or problems with the source code will not be supported by me either.


I suggest you visit the support forum for this: http://forums.rpgmakerweb.com/index.php?/forum/128-javascriptplugin-support/


---

about your class parameter plug in.....do the formulas work with plug ins that additional stats 


exsample:


HP = ((end*1.1)+(VIT*1.2)+(str*.75))*1.2


It doesn't alter the formulas of non-default stats. However, it can use those stats if and only if those stats do not depend on base stats.


---

Plugin Name: Row Formation

Error Message: user is not defined

ReferenceError: user is not defined
at Game_Actor.eval (eval at (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1254:10), :1:5)
at Game_Actor.Game_Battler.userRowEval (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1254:5)
at Game_Action.applyUserItemRowEffect (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1357:39)
at Game_Action.apply (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_RowFormation.js:1329:12)
at Function.BattleManager.invokeNormalAction (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/rpg_managers.js:2297:18)
at Function.BattleManager.invokeAction (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:1718:10)
at Function. (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:2307:14)
at Array.forEach (native)
at Function.BattleManager.actionActionEffect (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:2304:13)
at Function.BattleManager.processActionSequence (file:///C:/Users/Matteo/Documents/Games/Last%20Winter/js/plugins/YEP_BattleEngineCore.js:1917:19)rpg_managers.js:1722 SceneManager.catchException

How to Replicate Bug: use a skill with the tag //Custom User Row

Other: I must report a probable bug, but it's not my catch!
The original one is http://forums.rpgmakerweb.com/index.php?/topic/60893-yanfly-row-formation-lunatic-help/&_fromLogin=1#replyForm
I was trying to do something similar and found that the call to user give me a error.
I even tried to use the code provided in the plugin, but error pop up without mercy.


Seems like I forgot to add the "user" variable to that one. You can use 'a' or 'subject' or 'this' to refer to the user for the time being. I'll get this updated by tonight.
 

Audorn

Dabbler
Veteran
Joined
Apr 18, 2016
Messages
38
Reaction score
18
First Language
English
Primarily Uses
I'm afraid I can't help you with this as I'm only currently providing support for my own code and not code made by others, even if it's a snippet.


Just to be clear - One line was a simple 'equip actor' command (don't need any help with that), and the other was your code (a command from YEP_X_AttachAugments.js that I figured out how to use successfully in the console) - nothing I mentioned was from a different plugin, or from my origination.  


My posts are asking whether your plugins both are functioning as intended.  I only included the code to show you how to replicate the error quickly.


Plugin Name: YEP_X_ExtMesPack1   - When I use the PluginCommand DisableChoice #, the corresponding switch does not change from the ON state.  I can still toggle the switch manually and disable/enable the dialog choice, so I can still reference the switch to record the state of the dialog choice if I make sure to always toggle the dialog options via the switch and never use your PluginComman.  Is that intended or a bug?  


Plugin Name: YEP_X_AttachAugments - When I attempt to use the javascript command from within your plugin 'ItemManager.installAugmentToSlot(item, effectItem, slotId);' It crashes the game unless I have already looked at the augment slots within the Main Menu->Items->Equipment Category->Selected specific item.  Is that intended?


I have 22 of your plugins installed, updated, and carefully arranged in the plugin manager according to your examples.


I don't mean to pester, and perhaps I've been describing my findings poorly, but these seem like bugs to me.  If they are not, I'm sorry to bother you about them.  I just need to know whether to use the plugins as they are and figure out how to work within their functionality, or if indeed this is not intended behavior and should be reported.


Thank you for your time.

 

Crimson Dragon Inc.

Crimson Dragon
Veteran
Joined
Aug 8, 2012
Messages
925
Reaction score
135
First Language
english
Primarily Uses
RMMV
yanfly when using your classbaseparam plug in and using only the base formula's presented in your help text i get this error when trying to look at the status menu of the character that was used for testing the note tag





this is using only your plug ins in the order reccomended and turning off all other plug ins.......updated right before the test all plugins
 

Jonnah

Villager
Member
Joined
Apr 23, 2016
Messages
9
Reaction score
0
Primarily Uses
N/A
yanfly when using your classbaseparam plug in and using only the base formula's presented in your help text i get this error when trying to look at the status menu of the character that was used for testing the note tag





this is using only your plug ins in the order reccomended and turning off all other plug ins.......updated right before the test all plugins
I've reported this already, Yanfly said he was gonna fix it tonight, so just wait for the update I guess.
 

Crimson Dragon Inc.

Crimson Dragon
Veteran
Joined
Aug 8, 2012
Messages
925
Reaction score
135
First Language
english
Primarily Uses
RMMV
oh yeah forgot to mention when going to equip screen and looking at gears it gives stat -> nan and giving wrong stats for the formulas you put into place
 

Zheg

Veteran
Veteran
Joined
Apr 2, 2014
Messages
42
Reaction score
59
First Language
english
Primarily Uses
hey yanfly im having an error
when in equip section i press "Q" or "W" for prev/next actor i got this error.


http://i.imgur.com/iU2UL3Y.png

i dont know why this is happening, i dont have another plugins installed but yours.


thx
 

Yanfly

Developer
Joined
Mar 15, 2012
Messages
1,696
Reaction score
2,329
Just to be clear - One line was a simple 'equip actor' command (don't need any help with that), and the other was your code (a command from YEP_X_AttachAugments.js that I figured out how to use successfully in the console) - nothing I mentioned was from a different plugin, or from my origination.  


My posts are asking whether your plugins both are functioning as intended.  I only included the code to show you how to replicate the error quickly.


Plugin Name: YEP_X_ExtMesPack1   - When I use the PluginCommand DisableChoice #, the corresponding switch does not change from the ON state.  I can still toggle the switch manually and disable/enable the dialog choice, so I can still reference the switch to record the state of the dialog choice if I make sure to always toggle the dialog options via the switch and never use your PluginComman.  Is that intended or a bug?  


Plugin Name: YEP_X_AttachAugments - When I attempt to use the javascript command from within your plugin 'ItemManager.installAugmentToSlot(item, effectItem, slotId);' It crashes the game unless I have already looked at the augment slots within the Main Menu->Items->Equipment Category->Selected specific item.  Is that intended?


I have 22 of your plugins installed, updated, and carefully arranged in the plugin manager according to your examples.


I don't mean to pester, and perhaps I've been describing my findings poorly, but these seem like bugs to me.  If they are not, I'm sorry to bother you about them.  I just need to know whether to use the plugins as they are and figure out how to work within their functionality, or if indeed this is not intended behavior and should be reported.


Thank you for your time.


1. ExtMesPack1 - Yes, this is an intended effect as the plugin command/script call is meant to be an alternative for those who aren't using switches. But you raise a good point about synching the two and referencing the switch. I can make this change.


2. You may have taken the line of code out from the plugin itself, but you're skipping several steps that make an item augmentable, which is why it's crashing for you.
 

slycode

Warper
Member
Joined
Dec 2, 2014
Messages
3
Reaction score
0
First Language
English
Primarily Uses
@Yanfly, thanks for your amazing scripts, I've been having some problems with my code/Skill Learn System plugin. Can you take a look at it on the previous page and help me out? I haven't had much luck with it. Thanks!
 
Status
Not open for further replies.

Users Who Are Viewing This Thread (Users: 0, Guests: 9)

Latest Threads

Latest Posts

Latest Profile Posts

Gosh... Today seems too much like a good day to do nothing....

I need to keep myself focused...! :kaoback:
javascript'ing essentials.

So, what can I do solve this problem, guys? The plugin is MOG_Weather and I have several Yanfly plugins too.
This little brat (my nephew) just invent a new way of enjoying his orange juice by pouring it inside of used perfume bottle and sprayed it to his mouth...

Forum statistics

Threads
93,696
Messages
914,695
Members
123,292
Latest member
VinzBandicoot
Top