Status
Not open for further replies.

kaiserik

Warper
Member
Joined
Nov 28, 2013
Messages
1
Reaction score
0
First Language
French
Primarily Uses
@Yanfly

I want to use <Menu Visible Eval> from the Common Event Menu plugin but in that case, I can't use notetag but comment instead.
The problem is the size of the Comment window. Your example fits the size but in my case, my Javascript evaluation is too long and can't be set in the Comment Window because I need to indent the code.
 

Derpo

Veteran
Veteran
Joined
Feb 11, 2016
Messages
74
Reaction score
17
First Language
English
Primarily Uses
Plugin Name: YEP.116 – Grid-Free Doodad v1.03

Plugin Parameter Changes: None

Bug Explanation: There is a visual glitch caused by the way doodads are displayed on the map during vertical map movement being drawn.
All doodads will shift 1-2 pixels up during this process, as soon as the map is still, the doodads will be in place.

This is most apparent or noticable to the player when:
  • A: Using the Scroll Map
  • B: Actors walk at speeds 1,2,3
  • C: Large maps with many graphics or doodads
  • D: Playing Fullscreen

The problem does not occur with horizontal map drawing.

I've had this problem since the first release of the plugin and still have it with the latest version, I'm not sure why nobody has addressed it or if others dont find it bothersome. I use a LOT of doodads for both extra graphics and shading effects, I LOVE this plugin (seriously one of your best)
Unfortunately having every doodad jitter during play looks very intrusive, when they are supposed to fit tightly on to the Tileset graphics it looks even worse...


Error Report: I do not believe this bug would create and error report.

Exact Steps on How to Replicate Bug: Please follow the instructions inside the sample project.

Did you recreate the Bug on the Sample Project? Yes.

Clean Sample Project: --- CLICK HERE ---
The sample project comes with some instructions, however it is clean and stripped and only has this plugin installed.

Final Notes: I am not sure if this is a core problem with the way the plugin is made and draws the images. I have no knowledge about how this code works, but I have noticed that within MV, Tilesets and Event graphics are drawn differently. I've been able to recreate a similar jitter on Events (or more of a bounce) when walking slowly into the opposite direction of a map scroll. However it only occurs in very specific speed combinations, probably giving the engine trouble as to where exactly to draw the pixels.

It's a lot more noticeable with the doodads, and mostly it is more visually intrusive as the doodads are often supposed to feel like part of the map, or not 'alive' in general.

Also, please find included some screenshots from the Sample Project to illustrate
the issue.

Example%201.png


Example%202.png



Thanks for looking Yanfly, and again, I hate to nag about this because this is in my opinion one of the best plugins you've ever released!
 
Last edited:

ramza

Lunatic Coder
Veteran
Joined
Jan 28, 2013
Messages
943
Reaction score
593
First Language
English
Primarily Uses
RMMV
Greetings again @Yanfly I come bearing another bug report. Thanks in advance

Plugin Name:
YEP_BuffStatesCore
Do you have all the latest updates for the plugins in question? Yes
Plugin Parameter Changes: None
Bug Explanation: The lunatic mode tag for <Custom Remove Effect> doesn't occur in all situations in which it should. Specifically, if the state is removed due to the afflicted battler dying, the <Custom Remove Effect> doesn't happen. As there is no <Custom Death Effect> or anything similar, I suspect this is unintended. The problem also happens on allied battlers, though I didn't demonstrate that in the test project.
Are you a coder who understands the problem in code as to why this bug is caused? Not this time :).
Error Report: N/A
Exact Steps on How to Replicate Bug: Either test-play the bat x2 troop or start a new game in the test project and talk to the bat. The console log is used to indicate whether the state is doing what it's supposed to do or not.
Did you recreate the bug on the sample project? Yes.
Upload the sample project and share the link (ABSOLUTELY REQUIRED): Test Project
 

beelzebug

Warper
Member
Joined
Jan 22, 2016
Messages
3
Reaction score
1
First Language
English
Primarily Uses
Plugin Name: YEP_SaveEventLocations v1.05

Plugin Parameter Changes: None

Bug Explanation: When using a common event to move an event that has the notetag <Save Event Location>
the location is not saved, UNLESS the player interacts with the event before exiting the map.

Exact Steps on How to Replicate Bug:
Use the item that is in the chest to move the dog. Exit the map. Upon returning the dog is back in its original location. However, if you interact with the dog after using the item and exit the map, the dog's location will be saved.

Did you recreate the bug on the sample project? Yes.

Upload the sample project and share the link : Test Project

Hopefully I did this correctly. Thank you for your time and for making the plugin in the first place.


Update: I misunderstood what was going on. The common event is irrelevant it just doesn't save the location if it's moved with "Set event location."
 
Last edited:

SwiftIllusion

Veteran
Veteran
Joined
Jan 8, 2016
Messages
103
Reaction score
169
First Language
English
Primarily Uses
-bug report submission-
Plugin Name: "YEP_X_TurnOrderDisplay"

  • Do you have all the latest updates for the plugins in question?
  • Yes (though note: I'm using RPG Maker MV v1.3.4 after seeing some people being unable to open it after updating to v1.3.5)
    Plugin Parameter Changes:
  • None
    Bug Explanation:
  • When you enter a battle without a full party, the game black screens with "Cannot read property 'isDead' of undefined"
    EDIT: Found a solution
  • Replace line 496 "var length = $gameParty.maxBattleMembers();"
    with "var length = $gameParty.members().length;"
    It seems it was trying to create/read information for non-existent party members, because the length was larger than the active members.
    (I don't know if that would be enough for more complex circumstances like variable part member amounts with adding/removing party members during battle, but it fixes the bug above at least).

    Error Report:
    TypeError: Cannot read property 'isDead' of undefined
    at Window_TurnOrderIcon.updateDestinationX (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:766)
    at Window_TurnOrderIcon.initialize (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:559)
    at new Window_TurnOrderIcon (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:549)
    at Scene_Battle.createTurnOrderDisplay (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:498)
    at Scene_Battle.updateTurnOrderDisplayX (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:514)
    at Function.BattleManager.updateTurnOrderDisplayX (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:291)
    at Function.BattleManager.makeActionOrders (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:301)
    at Game_Action.clear (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:448)
    at Game_Action.initialize (rpg_objects.js:1213)
    at new Game_Action (rpg_objects.js:1187)
    Exact Steps on How to Replicate Bug:
    [*]Set any actor to "none" in the troops Battle Test window then press ok - image
    [*]The same thing occurs if you move around the map and encounter the troop naturally without a full party.
    (The map in the Sample Project is already set to trigger the encounter each step for testing purposes.)
    Did you recreate the bug on the sample project?
    [*]Yes
    Upload the sample project and share the link:
    [*]https://www.dropbox.com/s/ergcfk50r20r003/TurnOrderBugReproducable.zip?dl=0
 
Last edited:

sloths are ok

garbage boy
Member
Joined
Sep 5, 2016
Messages
14
Reaction score
9
First Language
English
Primarily Uses
RMMV
Plugin Name:
YEP.104 – New Game+ – RPG Maker MV



Do you have all the latest updates for the plugins in question?
Yes

Plugin Parameter Changes: (Mention ALL of the changes you've made to the plugin's parameters. Otherwise, I will revert every single plugin's settings to the default setting):
Carried Switches: 1,2


Bug Explanation: (What is the bug in your own words? Keep this detailed. "It isn't working right" is not a valid bug report.)"
The DisableNewGamePlus plugin command enables NewGamePlus.
I tried digging through the code but could not find nor fix the probem.
Once NewGame+ has been activated on a Save, there is no way to normally Load from that save.


Exact Steps on How to Replicate Bug: (Write out IN DETAIL, a step-by-step guide on how to replicate the bug.)
1. Start the project.
2. Start a new game
3. The top middle character only opens the save menu.
The top left character has the plugin command DisableNewGamePlus and then opens the save menu.
The top right character has the plugin command EnableNewGamePlus and then opens the save menu.
4. Saving with the top middle character creates a standard save with Load, Save, and Delete.
5. Saving with the top right character enables New Game Plus and presents the correct options: NewGame+, Save, and Delete.
6. Saving with the top left character, with NewGamePlus activated, creates a Save with the options: NewGame+, Save, and Delete.
7. Saving with the top left character without NewGamePlus activated, activates NewGamePlus, creating a save with the options: NewGame+, Save, and Delete.



Upload the sample project and share the link (ABSOLUTELY REQUIRED):
  1. https://www.dropbox.com/s/spdtxpe0iuh15t9/NewGame+Test.rar?dl=0

Thank you so much for your plugins. They have helped with my project immeasurably and this was the first issue I've run into using any of them. Your dedication to your work is wonderfully inspiring.

EDIT: Fixed the name of the plugin with the issue.
 

Alexandre

Veteran
Veteran
Joined
Jul 8, 2015
Messages
158
Reaction score
76
First Language
French
Primarily Uses
Plugin: State Categories (V 1.05)
Bug explanation: Documentation error. Notetag for Custom State Category Removal must be <Custom Remove State Category: text>.
 

Johan86

Villager
Member
Joined
Dec 26, 2016
Messages
22
Reaction score
96
First Language
English
Primarily Uses
RMMV
Hi, first I want to thank you for all these great plugins you are making!

Now I want to report a bug I think I found on Equip Battle Skills plugin. I dont know if this topic has been already discussed, but
in case it has not, I found a problem on the help window upon equiping or removing skills.

The bug is easy to describe so I dont think uploading anything is really necessary.

When I equip a new skill, or when I remove a skill, the help window gets stucked on the old skill description.
If I move the cursor right and back left, the problem gets fixed, so I figured its some kind of refresh problem.
I dont have much knowledge on JavaScript, but I tried adding a refresh command here and there, didnt fix the problem.
Also I turned off other plugins, even started a new project, but the problem is still there...

Any thoughts?
 

deathsia

Pegisister
Veteran
Joined
Feb 26, 2014
Messages
651
Reaction score
55
First Language
English
Primarily Uses
I encounter this error when using your "minion barrier" under tips and tricks:
2506aa70cc.png


Is there some kind of additional setup I need to do?
 

ShidoLionheart

Cuor di Leone
Veteran
Joined
Sep 21, 2013
Messages
62
Reaction score
33
First Language
Italian
Plugin : Battle Engine Core
Bug : When a skill targets all enemies and it's a skill selected directly from the list of skill (like the attack skill) the confirmation step is not working even if the parameter select hep window is set to true.
 

SoSick.

Veteran
Veteran
Joined
Jun 29, 2016
Messages
224
Reaction score
192
First Language
english
Primarily Uses
RMMV
Yanfly, the legend B):p
I use all of your plugin's all upto date. I'm trying to use auto-save in my poject..via script call..e.g
  • DataManager.saveGame(1);
  • $gameSystem.onBeforeSave();
    if (DataManager.saveGame(1)) {
    StorageManager.cleanBackup(1);
    }
and even some other's, also used an Auto-save plugin from Hudell... Nothing works, when I script call I get an error from e.g from your movement core, ill remove it and try again, I then get a different plugin of your's giving me the error like TP Enhance. There allways the same error with same lines in the plugin causing the problem.. what do you think could be causing the problem? has anyone else experienced this ? thankyou.
 

Attachments

  • yanfly 1.PNG
    yanfly 1.PNG
    39.3 KB · Views: 4
  • yanfly 2.PNG
    yanfly 2.PNG
    63.9 KB · Views: 4

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,776
Reaction score
2,684
@Yanfly: Indeed I did upload the wrong one. Let's try this again:


Warning: Because it is based on the same framework as the last one (I created a template project because I report so many bugs) this one may look the same as the AI core demo project when you first load it up. Navigate to the plugins folder in the google drive interface before downloading the file if you're worried I did it wrong again. ;)

Thanks, got it this time!

Plugin: Action Sequence Pack 2 (V 1.11), Animated Sideview Enemies (V 1.16), Visual State Effects (V 1.02) (Default settings)
Bug: The action sequence command "MOTION type: target, (no weapon)" has a wrong behavior for animated enemies when the plugin Visual State Effects is active.
After performing his motion, the animated enemy will hold the motion for a moment, while actors don't.
Project: http://www.mediafire.com/file/6d7vp0l7dt7h9cc/Debug.zip
Try the only battle available and compare how Lucius and Lucius' doppelgangers perform the special skill "Barrage".

Thanks, got it fixed. This appears to be a bug that was made due to the changes from the MV updates because I recall fixing this a while back. Guess it got "unfixed" due to it. Oh well, no biggie.

Plugin: Critical Control (V 1.03) (Default settings)
Bug: States with the notetags <Physical Critical Rate: +x%> affect both magical and physical critical rate, while states with the the notetag <Magical Critical Rate: +x%> doesn't have any effects.
Possible fix: Replace line 501: if (state) multiplier += state.physicalCritRateBonus;
by this line: if (state) multiplier += state.magicalCritRateBonus;

And got it!

Plugin Name: YEP_ClassChangeCore v1.12

Do you have all the latest updates for the plugins in question? Yes, v1.12


Plugin Parameter Changes: None


Bug Explanation: The problem is coming in with using ClassChangeCore and then the characters are not learning the skills at the approriate levels. I just want to toss a note in on this that it is not the same issue as stated on the main plugin page for multi classes having the same skills. My issue is that a character automatically obtains ALL skills within the skill type even though in the skills to learn section of the database only one skill would be listed. In my example game this is clearly visible. All classes within the database are non-modified and from a fresh project.

Hero Class: Contains the skill type "Magic" with two skills to learn at level 1 (Heal and Spark)

Warrior Class: Contains the skill type "Magic" with zero skills to learn

Mage Class: Contains the skill type "Magic" with one skills to learn item at level 1 (Fire)

Priest Class: Contains the skill type "Magic" with one skills to learn item at level 1 (Heal)

The issue is that straight from the gate once starting a new game... All of the classes automatically know ALL of the skills in the Magic skill type, even though the skills to learn section of the database is saying they should only know the above mentioned skills at level 1.


Are you a coder who understands the problem in code as to why this bug is caused? No.


Create a Sample Project Reproducing the bug: The sample project MUST follow all of these guidelines:
  1. Create a new project. Done.
  2. The project's file size must be 200 MB or LESS. Done.
  3. Install -only- the affected plugins. Done.
  4. Do -NOT- rename the plugins' filenames. Done.
  5. Make sure they're in the EXACT order listed on Yanfly.moe. Done.
  6. Do -NOT- deploy the project through File > Deployment. Do -NOT- box the sample project. Zipped original game files only.

Error Report: I do not believe this bug would create and error report.


Exact Steps on How to Replicate Bug: Start a new game, open the menu, select skill, select any character, see that each character has already obtained all skills even though the database has specific skills to learn level set.


Did you recreate the bug on the sample project? Yes.


Upload the sample project and share the link (ABSOLUTELY REQUIRED): https://www.dropbox.com/s/i2zvtical1rbkk9/Class Skill Learning Stripped.zip?dl=0

This isn't a bug. All your classes have them being learned at level 1. By default, all those classes are unlocked so all those skills are naturally learned, too.

Plugin Name: Improved BattleBacks
Do you have all the latest updates for the plugins in question? Yes
Plugin Parameter Changes: Not important because it has nothing to do with those
Bug Explanation: During the battle scene, if anything with the battlebacks has been altered (i.e making one of them scroll, adding additional layers of battlebacks, etc.) and the player brings up one of your scenes from a different plugin (like the row change screen or the party member switching scene), the battlebacks will revert to the default ones upon the player closing the other scene and returning to the battle.

This doesn't really effect altering the battlebacks temporarily for action sequences, but it does for making the battle scene look more alive during the whole battle. So, if you had a battle scene with a scrolling sky/a couple layers of moving backgrounds, it would stop scrolling after bringing up one of those other menu scenes. And any battleback layers above battlebacks 1 and 2 are gone entirely. I assume this has something to do with the scene refreshing?

Error Report: No error report.

Exact Steps on How to Replicate Bug: Begin a battle with Troop1 in the database. Press escape to bring up the party command menu and go to the party scene. Then leave that scene.

Did you recreate the bug on the sample project? Yes.

Upload the sample project and share the link (ABSOLUTELY REQUIRED):
https://www.mediafire.com/?pd3bk57v2g0cdwh

Thanks, this is actually an issue with the party change format. This will be updated.

Plugin Name: YEP.116 – Grid-Free Doodad v1.03

Plugin Parameter Changes: None

Bug Explanation: There is a visual glitch caused by the way doodads are displayed on the map during vertical map movement being drawn.
All doodads will shift 1-2 pixels up during this process, as soon as the map is still, the doodads will be in place.

This is most apparent or noticable to the player when:
  • A: Using the Scroll Map
  • B: Actors walk at speeds 1,2,3
  • C: Large maps with many graphics or doodads
  • D: Playing Fullscreen

The problem does not occur with horizontal map drawing.

I've had this problem since the first release of the plugin and still have it with the latest version, I'm not sure why nobody has addressed it or if others dont find it bothersome. I use a LOT of doodads for both extra graphics and shading effects, I LOVE this plugin (seriously one of your best)
Unfortunately having every doodad jitter during play looks very intrusive, when they are supposed to fit tightly on to the Tileset graphics it looks even worse...


Error Report: I do not believe this bug would create and error report.

Exact Steps on How to Replicate Bug: Please follow the instructions inside the sample project.

Did you recreate the Bug on the Sample Project? Yes.

Clean Sample Project: --- CLICK HERE ---
The sample project comes with some instructions, however it is clean and stripped and only has this plugin installed.

Final Notes: I am not sure if this is a core problem with the way the plugin is made and draws the images. I have no knowledge about how this code works, but I have noticed that within MV, Tilesets and Event graphics are drawn differently. I've been able to recreate a similar jitter on Events (or more of a bounce) when walking slowly into the opposite direction of a map scroll. However it only occurs in very specific speed combinations, probably giving the engine trouble as to where exactly to draw the pixels.

It's a lot more noticeable with the doodads, and mostly it is more visually intrusive as the doodads are often supposed to feel like part of the map, or not 'alive' in general.

Also, please find included some screenshots from the Sample Project to illustrate
the issue.

Example%201.png


Example%202.png



Thanks for looking Yanfly, and again, I hate to nag about this because this is in my opinion one of the best plugins you've ever released!

Thanks for the detailed explanation! This really helped out. I'll get this fixed come the next set of plugin updates!

Greetings again @Yanfly I come bearing another bug report. Thanks in advance

Plugin Name:
YEP_BuffStatesCore
Do you have all the latest updates for the plugins in question? Yes
Plugin Parameter Changes: None
Bug Explanation: The lunatic mode tag for <Custom Remove Effect> doesn't occur in all situations in which it should. Specifically, if the state is removed due to the afflicted battler dying, the <Custom Remove Effect> doesn't happen. As there is no <Custom Death Effect> or anything similar, I suspect this is unintended. The problem also happens on allied battlers, though I didn't demonstrate that in the test project.
Are you a coder who understands the problem in code as to why this bug is caused? Not this time :).
Error Report: N/A
Exact Steps on How to Replicate Bug: Either test-play the bat x2 troop or start a new game in the test project and talk to the bat. The console log is used to indicate whether the state is doing what it's supposed to do or not.
Did you recreate the bug on the sample project? Yes.
Upload the sample project and share the link (ABSOLUTELY REQUIRED): Test Project

Hmmm. This is actually due to the clearing process. It seems that when states are cleared (via death or event), they don't get removed, but straight emptied out. This may have to be something I'll have to implement at a later date after some testing.

Plugin Name: YEP_SaveEventLocations v1.05

Plugin Parameter Changes: None

Bug Explanation: When using a common event to move an event that has the notetag <Save Event Location>
the location is not saved, UNLESS the player interacts with the event before exiting the map.

Exact Steps on How to Replicate Bug:
Use the item that is in the chest to move the dog. Exit the map. Upon returning the dog is back in its original location. However, if you interact with the dog after using the item and exit the map, the dog's location will be saved.

Did you recreate the bug on the sample project? Yes.

Upload the sample project and share the link : Test Project

Hopefully I did this correctly. Thank you for your time and for making the plugin in the first place.


Update: I misunderstood what was going on. The common event is irrelevant it just doesn't save the location if it's moved with "Set event location."

Thanks for alerting me of this. I'll get this updated.

-bug report submission-
Plugin Name: "YEP_X_TurnOrderDisplay"

  • Do you have all the latest updates for the plugins in question?
  • Yes (though note: I'm using RPG Maker MV v1.3.4 after seeing some people being unable to open it after updating to v1.3.5)
    Plugin Parameter Changes:
  • None
    Bug Explanation:
  • When you enter a battle without a full party, the game black screens with "Cannot read property 'isDead' of undefined"
    EDIT: Found a solution
  • Replace line 496 "var length = $gameParty.maxBattleMembers();"
    with "var length = $gameParty.members().length;"
    It seems it was trying to create/read information for non-existent party members, because the length was larger than the active members.
    (I don't know if that would be enough for more complex circumstances like variable part member amounts with adding/removing party members during battle, but it fixes the bug above at least).

    Error Report:
    TypeError: Cannot read property 'isDead' of undefined
    at Window_TurnOrderIcon.updateDestinationX (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:766)
    at Window_TurnOrderIcon.initialize (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:559)
    at new Window_TurnOrderIcon (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:549)
    at Scene_Battle.createTurnOrderDisplay (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:498)
    at Scene_Battle.updateTurnOrderDisplayX (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:514)
    at Function.BattleManager.updateTurnOrderDisplayX (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:291)
    at Function.BattleManager.makeActionOrders (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:301)
    at Game_Action.clear (/D:/RPGmangaTest/Test/Project1/js/plugins/YEP_X_TurnOrderDisplay.js:448)
    at Game_Action.initialize (rpg_objects.js:1213)
    at new Game_Action (rpg_objects.js:1187)
    Exact Steps on How to Replicate Bug:
    [*]Set any actor to "none" in the troops Battle Test window then press ok - image
    [*]The same thing occurs if you move around the map and encounter the troop naturally without a full party.
    (The map in the Sample Project is already set to trigger the encounter each step for testing purposes.)
    Did you recreate the bug on the sample project?
    [*]Yes
    Upload the sample project and share the link:
    [*]https://www.dropbox.com/s/ergcfk50r20r003/TurnOrderBugReproducable.zip?dl=0

Thanks for letting me know!

Plugin Name:
YEP.104 – New Game+ – RPG Maker MV



Do you have all the latest updates for the plugins in question?
Yes

Plugin Parameter Changes: (Mention ALL of the changes you've made to the plugin's parameters. Otherwise, I will revert every single plugin's settings to the default setting):
Carried Switches: 1,2


Bug Explanation: (What is the bug in your own words? Keep this detailed. "It isn't working right" is not a valid bug report.)"
The DisableNewGamePlus plugin command enables NewGamePlus.
I tried digging through the code but could not find nor fix the probem.
Once NewGame+ has been activated on a Save, there is no way to normally Load from that save.


Exact Steps on How to Replicate Bug: (Write out IN DETAIL, a step-by-step guide on how to replicate the bug.)
1. Start the project.
2. Start a new game
3. The top middle character only opens the save menu.
The top left character has the plugin command DisableNewGamePlus and then opens the save menu.
The top right character has the plugin command EnableNewGamePlus and then opens the save menu.
4. Saving with the top middle character creates a standard save with Load, Save, and Delete.
5. Saving with the top right character enables New Game Plus and presents the correct options: NewGame+, Save, and Delete.
6. Saving with the top left character, with NewGamePlus activated, creates a Save with the options: NewGame+, Save, and Delete.
7. Saving with the top left character without NewGamePlus activated, activates NewGamePlus, creating a save with the options: NewGame+, Save, and Delete.



Upload the sample project and share the link (ABSOLUTELY REQUIRED):
  1. https://www.dropbox.com/s/spdtxpe0iuh15t9/NewGame+Test.rar?dl=0

Thank you so much for your plugins. They have helped with my project immeasurably and this was the first issue I've run into using any of them. Your dedication to your work is wonderfully inspiring.

EDIT: Fixed the name of the plugin with the issue.

Thanks for letting me know! I'll get this fixed.

---

For the users who did not include sample projects, please remember to do so as it is a requirement for me to consider the bug reports. Here is why:

WHY I NEED A CLEAN SAMPLE PROJECT FOR BUG REPORTS:

If you're wondering why I make it an absolute requirement for sample projects containing to be made, it's because in the past, I've chased and hunted bugs that do not exist either because a user had a conflicting error with a non-Yanfly plugin, has not updated the plugins, using the plugin incorrectly, or think something is a bug when it really isn't. The amount of time I've wasted chasing these "bugs" is unfathomable as that time could have been spent developing new content. To mitigate this issue, I made it an absolute requirement for bugs to be reported in such a manner because of the following:
  1. It makes the user go through all of the troubleshooting steps to reduce the amount of user errors. If the user identifies it as a user error, then the user would also have gained troubleshooting skills, which are essential for game development. If you cannot be bothered to learn how to troubleshoot, I'm afraid RPG Maker will be giving you a whole lot more stress later on.
  2. Isolate the bugs caused by Yanfly plugins away from non-Yanfly plugins. As stated above, I do not provide support for non-Yanfly plugins due to my lack of time to create compatibility patches for non-Yanfly plugins. Having over 100+ plugins, making a compatibility patch for each one of those with every other plugin out there is absolute insanity.
  3. It shows that the user is serious about getting the bug fixed as I am. Being able to put out time to isolate a problem so it can be fixed means the user is serious about getting their game made. If you are not serious about getting a bug fixed for your game, then I have no reason to be serious about getting it fixed for you. As a user's time is important to them, my time is also important to me, and this is our mutual agreement to get things done cooperatively.
Thank you for understanding.
 

sloths are ok

garbage boy
Member
Joined
Sep 5, 2016
Messages
14
Reaction score
9
First Language
English
Primarily Uses
RMMV
Thanks for letting me know! I'll get this fixed.
.

If this helps at all, JCHNanaya on YouTube (In the comments section on your New Game+ Video) provided a Script that acts as the Disable command:
$gameSystem._newGamePlusLoops = 0;
$gameSystem._newGamePlusLoaded = false;
$gameSystem._newGamePlusEnabled = false;
 

Johan86

Villager
Member
Joined
Dec 26, 2016
Messages
22
Reaction score
96
First Language
English
Primarily Uses
RMMV
Plugin Name: Equip Battle Skills

Do you have all the latest updates for the plugins in question?
Yes, V1.11

Plugin Parameter Changes: None.

Bug Explanation:
When you equip a new skill, or when you remove a skill, the help window displays the previous skill description. For example, try to remove the heal skill that is already equiped. You will see that although in the skills window it is an "Empty'' slot, the help window still has the heal skill's description. If you move the cursor right and back left, the problem gets fixed but it happens every time you change or you remove a skill.

Are you a coder who understands the problem in code as to why this bug is caused? No

Error Report: There are not any error messages, It is a display bug.

Exact Steps on How to Replicate Bug: Go to the Skills menu, equip or remove a skill and check the skill description on the help window.

Did you recreate the bug on the sample project? Yes.

Upload the sample project and share the link: http://www.mediafire.com/file/mb53061r253jgks/Bug+Report.rar
 

ShidoLionheart

Cuor di Leone
Veteran
Joined
Sep 21, 2013
Messages
62
Reaction score
33
First Language
Italian
Plugin : Battle Engine Core conflicts with Weapon Unleash
Do you have all the latest updates for the plugins in question? : YES
Bug
: When a skill targets all enemies and it's a skill selected directly from the list of skill (like the attack skill) the confirmation step is not working even if the parameter select hep window is set to true.
Did you recreate the bug on the sample project? : YES
Sample Project :
 

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,776
Reaction score
2,684
Plugin Name: Equip Battle Skills

Do you have all the latest updates for the plugins in question?
Yes, V1.11

Plugin Parameter Changes: None.

Bug Explanation:
When you equip a new skill, or when you remove a skill, the help window displays the previous skill description. For example, try to remove the heal skill that is already equiped. You will see that although in the skills window it is an "Empty'' slot, the help window still has the heal skill's description. If you move the cursor right and back left, the problem gets fixed but it happens every time you change or you remove a skill.

Are you a coder who understands the problem in code as to why this bug is caused? No

Error Report: There are not any error messages, It is a display bug.

Exact Steps on How to Replicate Bug: Go to the Skills menu, equip or remove a skill and check the skill description on the help window.

Did you recreate the bug on the sample project? Yes.

Upload the sample project and share the link: http://www.mediafire.com/file/mb53061r253jgks/Bug+Report.rar

Thanks. I'll get this fixed.

Plugin : Battle Engine Core conflicts with Weapon Unleash
Do you have all the latest updates for the plugins in question? : YES
Bug : When a skill targets all enemies and it's a skill selected directly from the list of skill (like the attack skill) the confirmation step is not working even if the parameter select hep window is set to true.
Did you recreate the bug on the sample project? : YES
Sample Project :

This is not a bug. I left it intentionally this way.
 

Yanfly

Veteran
Joined
Mar 15, 2012
Messages
1,776
Reaction score
2,684
YEP.126 – Extended Move Pack 1 – RPG Maker MV


This plugin adds extra simplified move routes for your events with the main intention of creating specific behaviors in movement patterns. The patterns include the option to hug a side of the wall and move along that, moving a single direction until coming to a stop, relative opacity adjusting, and index shifting.

Plugin Download: http://yanfly.moe/2017/02/25/yep-126-extended-move-pack-1-rpg-maker-mv/
 

Alexandre

Veteran
Veteran
Joined
Jul 8, 2015
Messages
158
Reaction score
76
First Language
French
Primarily Uses
Plugin Name: States Categories

Do you have all the latest updates for the plugins in question?
Yes, V1.05

Plugin Parameter Changes: None.

Error(s): None.

Bug Explanation:
The lunatic notetag to make Custom State Category Removal doesn't have any effects.

Are you a coder who understands the problem in code as to why this bug is caused? Yes. It is a documentation error:
the right notetag should be <Custom Remove State Category: text>, instead of
<Custom Remove State: category name>.
 
Last edited:

HomickNation

Villager
Member
Joined
Nov 27, 2016
Messages
6
Reaction score
0
First Language
English
Primarily Uses
RMMV
This isn't a bug. All your classes have them being learned at level 1. By default, all those classes are unlocked so all those skills are naturally learned, too.


Hero Class: Contains the skill type "Magic" with two skills to learn at level 1 (Heal and Spark)

Warrior Class: Contains the skill type "Magic" with zero skills to learn

Mage Class: Contains the skill type "Magic" with one skills to learn item at level 1 (Fire)

Priest Class: Contains the skill type "Magic" with one skills to learn item at level 1 (Heal)


Thank you for the reply sir, however i do not understand. All of my classes do not have this learned. In my submitted sample project as i have stated in also my reply for instance warrior class has zero skills to be learned at level 1 setup in the database... And all of the skills available he knows when start of new game. When i disable the classchangecore plugin and start new game from my sample project the warrior shows zero skills learned as the database shows, when enabled the warrior has all skills learned even though database has none of the skill specified to learn.
 

Kilitar

Veteran
Veteran
Joined
Jul 28, 2015
Messages
141
Reaction score
44
First Language
czech
Primarily Uses
RMMV
Plugin Name: YEP.65 – Extended Message Pack 1


Do you have all the latest updates for the plugins in question?
Yes, V1.10

Plugin Parameter Changes: None.

Error(s): None.

Bug Explanation:
Description bug on plugin help section (and on Yanfly web page as well)

Are you a coder who understands the problem in code as to why this bug is caused?
Newbie coder but I can read deascription :).


MessagePositionXAuto
– Sets the Message Window’s X Position to be automatically fitted and not set relative to its vertical (horizontal) anchor point.

MessagePositionYAuto
– Sets the Message Window’s Y Position to be automatically fitted and not set relative to its vertical anchor point.

MessageAnchorX left
– Sets the Message Window’s x anchor to ‘left’, ‘center’, or ‘right’ if you are using specified coordinates.

MessageAnchorY bottom
– Sets the Message Window’s y anchor to ‘left’, ‘center’, or ‘right’ (top, center, bottom) if you are using specified coordinates.
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Can't believe my code from four years ago is still working! Did some expansions, and...
1635194553179.png
In related news, I may have an update for my old Extra status window plugin ready. That is, once I manage to sit down and update the documentation... and the demo project... :kaoswt:
How does one pronounce Godot? I've heard it pronounced a couple of different ways, and I genuinely don't know the proper way.
March 2020 ...
1635188823939.jpeg
... vs October 2021
You look like you had a rough day...Here, have a Baby Panda!

7 years of trying to plan this project... and it got an official plotline today. 7 years. I really just have no concept of order huh GHJGSJHGVGHASFH.

Forum statistics

Threads
116,077
Messages
1,095,531
Members
151,438
Latest member
NBV
Top