Status
Not open for further replies.

Aurawhisperer

Veteran
Veteran
Joined
Jun 10, 2015
Messages
403
Reaction score
17
First Language
English
Primarily Uses
@Yanfly

Unsure whether this is a bug issue or not, but I encountered a problem based on the STB (Standard Turn Battle) system you made. The system does not acknowledge the battle events under the troop tab effectively like it should to dtb. It'll acknowledge a tab, depending on the conditions. For mine, it was checking the enemies HP % whether conditions are met or not. There's four tabs, each one label 75%, 50%, 10%, and 0%. Only tab 75% is acknowledged, whereas thee others are ignored. Not sure if this situation has been reported, if not it's something new.
I checked to ensure all plugins are up to date and tested dtb to ensure this issue didn't just effect stb. It only effects stb.
 

rpgkylon

Villager
Member
Joined
Nov 7, 2013
Messages
15
Reaction score
2
First Language
English
Primarily Uses
Plugin Name: YEP_BattleSysSTB

Do you have all the latest updates for the plugins in question? Yes

Plugin Parameter Changes:
Just changed the graphic of the enemy icon

Bug Explanation:
https://forums.rpgmakerweb.com/index.php?threads/issue-with-battle-event.80477/

Exact Steps on How to Replicate Bugs: The issue is, when the enemy dies, I wanted more enemies to spawn in a way where it basically split from the boss.

I have it set to after the end of the battle, four more enemies pop up cause the slime split into four.

I set the skill for the enemy to actually die and have a collapse animation, however after killing the four slimes the game treats it as if the battle is not over yet.

The setup action I use.

<setup action>
collapse: user
</setup action>


After the battle
6r23uv.png


The event setup
2uo4aza.png


Could anyone assist me, please?

I also test it without STB and it works perfectly without it.
 

Aurawhisperer

Veteran
Veteran
Joined
Jun 10, 2015
Messages
403
Reaction score
17
First Language
English
Primarily Uses
I am wondering if this is a plugin problem. Tested only yanflys core, battle core, and battlestb on a different file. Made a enemy troop with 3 tabs, along with stb active. The three tabs were acknowledged.

Give me a sec to upload it.

Edit: Won't let me upload .-.
 

rpgkylon

Villager
Member
Joined
Nov 7, 2013
Messages
15
Reaction score
2
First Language
English
Primarily Uses
I am wondering if this is a plugin problem. Tested only yanflys core, battle core, and battlestb on a different file. Made a enemy troop with 3 tabs, along with stb active. The three tabs were acknowledged.

Give me a sec to upload it.

Edit: Won't let me upload .-.
we seem to have the same issue, so I'll just upload mine.
 

LazyCtrlF

Warper
Member
Joined
Jun 28, 2017
Messages
2
Reaction score
0
First Language
English
Primarily Uses
RMMV
Linking me specifically to page 232 was actually a big help. It's a shame that the program itself doesn't have much in the way of support for tick programming. Hopefully the next RPG Maker can do that. I know that has little bearing in relevance to Yanfly, I'm just saying, maybe Enterbrain/Kadokawa could notice how their product is being used and make one that's even easier to use.
 

Deadpola

Veteran
Veteran
Joined
Apr 7, 2014
Messages
35
Reaction score
1
First Language
Italian
Primarily Uses
Probably was already asked but.
I have installed the Grid-free Doodas, placed the .json file and the doodas folder into img but f10 still won't open the "console"
other fx function works like full screen ecc
 

Kes

Veteran
Veteran
Joined
Aug 3, 2012
Messages
22,305
Reaction score
11,734
First Language
English
Primarily Uses
RMVXA
@Aurawhisperer Check the Opening Post - Yanfly is very explicit that unless a bug report is done in a specific way, then it will be ignored. You need to redo your report so that it fits with requirements.
 

Tatsumaro

Veteran
Veteran
Joined
Aug 11, 2016
Messages
205
Reaction score
40
First Language
Portugues
Primarily Uses
RMMV
Plugin Name: YEP_SaveEventLocations
Plugin Parameter Changes: None
Are you a coder: Nope

Bug Explanation: Hello i fund a compatibly bug between YEP_MoveRouteCore and YEP_SaveEventLocations. when you hate <Save Event Locations> notetag on the map, you cant use the TELEPORT: x, y Script in an Event.

Link to the Project
 
Last edited:

Aurawhisperer

Veteran
Veteran
Joined
Jun 10, 2015
Messages
403
Reaction score
17
First Language
English
Primarily Uses
Plugin Name: YEP_BattleSysSTB

Do you have all the latest updates for the plugins in question? Yes

Plugin Parameter Changes:
Acknowledging Battle Event tabs whenever HP is true to %

Bug Explanation:
Only acknowledges tab one, and ignores the other. Tested just the Main Core, Battle Core, and STB plugin on a different file with similar situation, and encounter no issue. This is happening only in my main project.

Exact Steps on How to Replicate Bugs: Whenever the enemy boss hits a certain % of HP, it suppose to react in each tab. Such as 75%, he releases Darkaga. 50%, he summons the undead girl. 10%, he unleashes three darks. 0%, he dramatically screams and dies.

I don't have a sample project, but I do have a screenshot of my boss event. I'll post four of them.

upload_2017-6-29_12-47-40.pngupload_2017-6-29_12-47-54.pngupload_2017-6-29_12-48-7.pngupload_2017-6-29_12-48-17.png

Been having this problem for going on a week, and can't seem to figure out why it's doing this.

Edit: Here's the stb test I was talking about: https://www.dropbox.com/home?preview=StbIssue.zip
 
Last edited:

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
561
Reaction score
349
First Language
English
Primarily Uses
RMMV
Plugin Name: YEP_BattleSysSTB

Do you have all the latest updates for the plugins in question? Yes

Plugin Parameter Changes:
Acknowledging Battle Event tabs whenever HP is true to %

Bug Explanation:
Only acknowledges tab one, and ignores the other. Tested just the Main Core, Battle Core, and STB plugin on a different file with similar situation, and encounter no issue. This is happening only in my main project.

Exact Steps on How to Replicate Bugs: Whenever the enemy boss hits a certain % of HP, it suppose to react in each tab. Such as 75%, he releases Darkaga. 50%, he summons the undead girl. 10%, he unleashes three darks. 0%, he dramatically screams and dies.

I don't have a sample project, but I do have a screenshot of my boss event. I'll post four of them.

View attachment 67518View attachment 67519View attachment 67520View attachment 67521

Been having this problem for going on a week, and can't seem to figure out why it's doing this.

Edit: Here's the stb test I was talking about: https://www.dropbox.com/home?preview=StbIssue.zip

Hey there, I've had the same issue in the past. I read somewhere that it was due to some incompatibility with certain yanfly plugins and the force action command. When I would remove the force action the troop events would work properly. Maybe try removing the forced actions you have in the troop events and see if the pages run properly. I just ended up not using forced actions in battle events as my fix.:smile:
 

Aurawhisperer

Veteran
Veteran
Joined
Jun 10, 2015
Messages
403
Reaction score
17
First Language
English
Primarily Uses
Hey there, I've had the same issue in the past. I read somewhere that it was due to some incompatibility with certain yanfly plugins and the force action command. When I would remove the force action the troop events would work properly. Maybe try removing the forced actions you have in the troop events and see if the pages run properly. I just ended up not using forced actions in battle events as my fix.:smile:

Well crap. That was the point then. To use it x.x
Is it due to the fact it's turn by turn and not all at once like the default?
 

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
561
Reaction score
349
First Language
English
Primarily Uses
RMMV
Well crap. That was the point then. To use it x.x
Is it due to the fact it's turn by turn and not all at once like the default?
I'm not sure but for me I had only 1 instance of a forced action in a set of troop pages when I encountered the issue. I had spent a whole day trying to find a way around the problem with no luck other than removing the forced action. I am pretty sure I did try a single page with the forced action but can't be sure. There may be some other way around the issue but I wasn't able to find it. For me it wasn't as important in my battle as it looks like it is for you so I just decided to do without but maybe someone in the community has found a way to make it work. Sorry I can't be more helpful on this one.
 

Aurawhisperer

Veteran
Veteran
Joined
Jun 10, 2015
Messages
403
Reaction score
17
First Language
English
Primarily Uses
I'm not sure but for me I had only 1 instance of a forced action in a set of troop pages when I encountered the issue. I had spent a whole day trying to find a way around the problem with no luck other than removing the forced action. I am pretty sure I did try a single page with the forced action but can't be sure. There may be some other way around the issue but I wasn't able to find it. For me it wasn't as important in my battle as it looks like it is for you so I just decided to do without but maybe someone in the community has found a way to make it work. Sorry I can't be more helpful on this one.

Na don't be. Thank you for the heads up. That means I won't be able to use even the STB system unfortunately. My game is suppose to be diverse
 

YoraeRasante

Veteran
Veteran
Joined
Jun 6, 2014
Messages
1,647
Reaction score
428
First Language
Portuguese
Primarily Uses
RMMV
Plugin Name: YEP_X_SelectionControl

Do you have all the latest updates for the plugins in question? Yes

Plugin Parameter Changes: None

Bug Explanation: If for any reason Attack can't have any selectable target, the whole actor gets disabled: Attack, Guard, all Skills, and no items are available to use, locking the game on the actor. Other YEP plugins can mitigate the damage, but it is still there.
There are also other lesser problems with the same source, but this is the one I saw first.

Are you a coder who understands the problem in code as to why this bug is caused? In the SelectionControlCache functions, both getSelectionControlCache and setSelectionControlCache, it is set so var id = item. It should instead be var id = item.id
My Fix: https://www.dropbox.com/s/qk2ey3jshbplnt6/YR_YEP_SC_Fix.js?dl=0
 
Last edited:

Nirwanda

Procrastimancer
Veteran
Joined
Nov 2, 2012
Messages
1,291
Reaction score
610
First Language
Spanish
Primarily Uses
RMMV
Nevermind this post: the bug was actually a plugin conflict.
 
Last edited:

padr81

Guy whose game is taking too long.
Veteran
Joined
Apr 26, 2013
Messages
739
Reaction score
757
First Language
english
Primarily Uses
N/A
Plugin Name: YEP_GridFreeDoodads

Do you have all the latest updates for the plugins in question? Yes

Plugin Parameter Changes: None

Bug Explanation: With GFD turned on, opening the menu will not load the actor face on the first try. Opening closing and then re-opening will. Or simply opening a sub-menu once its loaded the first time. Turning off Doodads removes the issue completely. This happens with or without the doodads extension plugin. To re-create in uploaded project simply start the game, Open the Menu (notice no character face), close menu and reopen and character face has reappeared.

Are you a coder who understands the problem in code as to why this bug is caused? Nope sorry.

But there is a fix posted on the next page by @Squack Spencer
https://forums.rpgmakerweb.com/inde...b-plugin-count-130.48860/page-302#post-751513

Project Link (Total Size 20mb): https://www.dropbox.com/sh/hdnbzyfli3waqev/AADZ7nSugYAtPoUUvgAwGj4va?dl=0
 
Last edited:

MikeRPG33

Veteran
Veteran
Joined
Jun 8, 2015
Messages
49
Reaction score
1
First Language
English
Primarily Uses
Plugin Name: YEP.88 – Picture Common Events ver. 1.05


Do you have all the latest updates for the plugins in question? Yes

Plugin Parameter Changes: None

Bug Explanation: Got everything set up but when I use the MovePlayer Down, Up, Left, Or Right Command, noting happens, Tried the TriggerButton Left, Up, ect.. as well. Nothing happens. Updated RMMV to 1.5.0 All other Commands work expect moving the player.

Are you a coder who understands the problem in code as to why this bug is caused? No
 
Status
Not open for further replies.

Latest Threads

Latest Posts

Latest Profile Posts

Under normal circumstances this would probably be the 4th time this year I'd say "hey guys I'm back", but honestly I might as well just drop a casual: hey guys how you doing lately?
T4aUVB5.jpg

And then flee.
Mouse Coordinates + Common Events, Custom Actor Parameters & Fantasy Beasts | RPG Maker News #32

BillyJack wrote on RachelTheSeeker's profile.
Checking out your profile pic. Check out missmabs.com and see wildy. http://missmab.com/Cast/wildy.php

Great comic if you havent read it.
Winter Cover.png
Peeps, can we just take some time to appreciate the mods here? They're so friendly, and they're always there for us when we need help. Now that I've been here for two years, I want to thank the mods and admins for keeping it positive here on the forum. They're the reason I've stayed so long! Here's to you!

Forum statistics

Threads
111,123
Messages
1,058,529
Members
144,346
Latest member
ManYouForgot
Top