[YEP] Yanfly Engine Plugins

Discussion in 'JS Plugin Releases (RMMV)' started by Yanfly, Nov 2, 2015.

Thread Status:
Not open for further replies.
  1. Chaos17

    Chaos17 Dreamer

    Messages:
    1,233
    Likes Received:
    396
    Location:
    France
    First Language:
    French
    Yanfly doen't take suggestion here, you need to subscribe to her patreon and sumit your suggestion in the suggestion box. This thread is only for bug reports :(
     
  2. DarkEspeon

    DarkEspeon Veteran

    Messages:
    83
    Likes Received:
    13
    First Language:
    Russian
    Primarily Uses:
    RMMV
    It's kind of sad, tbh. I can imagine people on patreon suggesting only what they need, omitting QoL changes. Though I have no way of knowing, it's just how I feel.
     
  3. flynn_the_fire

    flynn_the_fire Warper

    Messages:
    2
    Likes Received:
    0
    Bug report :
    Plugins:
    RowFormation, BattleSysCTB
    Explanation: There is an incompatibility between these plugins. In battle, when we exit the Rows menu, the screen refreshes and the turn order disappears until the end of the battle.
     
  4. DarkEspeon

    DarkEspeon Veteran

    Messages:
    83
    Likes Received:
    13
    First Language:
    Russian
    Primarily Uses:
    RMMV
    He's not gonna fix CTB, he said that many times.
     
  5. DavidFoxfire

    DavidFoxfire Veteran

    Messages:
    213
    Likes Received:
    40
    Location:
    St. Louis, MO
    Plugin Name: YEP External Links. (All Plugins and MV program updated.)

    Question: Is it possible to use an External Link to a web page that you created using the same Local Drive Directory as the game?

    I see myself distributing the game in a zip file with a FAQ file, written in HTML, on a separate web page. I'd like to set up the plug-in's parameters to do something like this:

    Home Page URL: faqindex.html
    Home Page Text: FAQ Page

    Is that possible with this Plug-In, or would I need another. Thanks in advance.
     
  6. Grunwave

    Grunwave Veteran

    Messages:
    141
    Likes Received:
    21
    First Language:
    English
  7. deathsia

    deathsia Pegisister

    Messages:
    572
    Likes Received:
    44
    First Language:
    English
    So after performing your custom 1.5 update, going to each individual plugin, opening it, and hitting okay, saving and then launching it, the first two times it crashed shortly after launch the following times, sound seemed to be working but this was all I saw in the window:
    [​IMG]

    and this is what my log says:
    [​IMG]
     
  8. Ebano

    Ebano Warper

    Messages:
    1
    Likes Received:
    0
    First Language:
    Spanish
    Primarily Uses:
    RMMV
    [Bug Report]

    Plugin Name: YEP.88 – Picture Common Events


    Do you have all the latest updates for the plugins in question? Yes


    Plugin Parameter Changes: Just asign Pictures in Common Events


    Bug Explanation:
    I did a puzzle rock pushing with the capacity to pull the rock backwards, to do that:

    upload_2017-8-31_20-35-22.png

    *EDIT: In the image the Trigger of the event is "Action button" but that was just for testing purposes. The real trigger is "event touch"

    I know is in spanish but It's just necesary to understand the first line, "If Ok button is pressed"

    Here comes your plugin
    upload_2017-8-31_20-37-51.png

    Common Event: TriggerButton Ok

    But, if you try to activate the Event using this Command the Event does not recognize that you are pressing Ok button so, instead of pull the rock the event push the rock. Making impossible to solve the puzzle

    Note that you can press Espace or Enter and the code is working properly but in an android device you cant press Espace or Enter :p

    Any ideas? :(
     
    Last edited: Sep 1, 2017
  9. Oscar92player

    Oscar92player Veteran

    Messages:
    298
    Likes Received:
    125
    Location:
    Benalmádena - Málaga - Spain
    First Language:
    Spanish
    Primarily Uses:
    RMMV
    [BUG REPORT]

    Plugin name: YEP.02- Message Core (v1.19)

    Bug explanation: After the Batch update for this plugin, the tag codes <br> and <line break> have stopped working, and breaks dialogues or texts in help windows now. This codes works in descriptions when using the <WordWrap> code, yes, but before the Batch update, the descriptions were making the line break without using it. Neither works in some description windows even changing the Plugin parameter "Description wrap", like in your Save Core plugin or other plugins that uses the help windows.

    Error report: No log errors in the Console window (aside from the "Deprecation warning" with PIXI).

    Exact steps on how to replicate the bug:
    1. Download the sample project and open it; then open the Database.
    2. Open the "Skills" tab, and see the description of the "Heal" spell. You'll see that I'm using the code <br> in the description to make a line break.
    3. Now, close the Database, and play the game.
    4. Start a new game, and open the Main menu. Then, go to "Skill" and select Harold.
    5. Select the spell "Heal" and see the description.
    You'll see the text:
    Code:
    Recovers HP.Can be used in battle or menus.
    Instead of:
    Code:
    Recovers HP.
    Can be used in battle or menus.
    This issue does not happen with the previous versions of the plugin, so I'm currently using the Message Core v1.18.​

    Sample project (REQUIRED): Tiny MV Project (v1.5.0) Message Core Report
    (Note: I'm using a tiny sample project updated with the last version of MV created by SumRdnDde).

    Hope you can fix this plugin soon, I would like to use the newest Batch Updates!
     
    Last edited: Sep 2, 2017
  10. Alexander Hawksmoor

    Alexander Hawksmoor Veteran

    Messages:
    198
    Likes Received:
    397
    Location:
    England
    First Language:
    English
    Primarily Uses:
    RMMV
    Before I report this as a bug, can anyone who uses yanfly's grid free doodads if they are having an issue where the doodads seem to jump left and right when the camera follows the player whilst in game?
     
  11. sb~

    sb~ Villager

    Messages:
    13
    Likes Received:
    3
    First Language:
    English
    There's a similar compatibility issue with ATB since the 1.5 batch updates. I understand Yanfly has discontinued support, but I will report it here in the off chance someone knows how to fix it.

    [BUG REPORT]

    Plugin name: YEP.54 – Row Formation (v1.15), YEP.24 - Battle System – Active Turn Battle (v1.26)

    Bug explanation:
    If I try to change rows mid-combat, a party member visually stays in the same row if he/she has recently performed an action (e.g. Guard) and is currently filling up his/her ATB gauge.

    Severity:
    Minor issue, not game breaking.
     
  12. Kilitar

    Kilitar Veteran

    Messages:
    127
    Likes Received:
    31
    First Language:
    czech
    Primarily Uses:
    RMMV
    [BUG REPORT]

    Plugin name: Move Route Core YEP_MoveRouteCore.js (1.01)


    Bug explanation: script "TELEPORT: PLAYER" followed by script UP: 1 (or any number/direction) does not work in case of repeated movement inside autonomous movement - custom route movement table.

    Error report: No errors.

    Exact steps on how to replicate the bug:
    1. Download the sample project and start game.
    2. Touch evil man, he switch to lightning image
    3. Lightning should have to hit a tile 1 point up from player every 2 seconds. (set transparent - move to player - move up 1 - set visible, hit tile - set transparent, wait 120frames. lightning has "repeated movement"
    4. First "tile hit" is fine, but next one ignores teleport command and hit 2 tiles above former player position (even not actual one). Third hit is 3 tiles above and so on.
    If the same movement route is used inside event TAB - it works flawlesly - bug appears only inside custom route within autonomous movement. (You can check page 2 and page 3 of lightning event)

    Sample project (REQUIRED): https://mega.nz/#!QOx1XJLS!WYolpQfuH_ME0bgI8pXyOosbEWSj7UllQZsdP3ap4vM
     
  13. kokuromi

    kokuromi Veteran

    Messages:
    46
    Likes Received:
    2
    Primarily Uses:
    N/A
    [BUG REPORT]

    Plugin name: X_EquipCustomize plugin


    Bug explanation: when using that plugin with item core's option "updated scene item" to false causes an error when trying to access the equip scene in game

    Error report: TypeError: Cannot read property 'apply' of undefined, SceneManager.catchException

    Exact steps on how to replicate the bug:
    1. use engine/item/equip core plugins and x_equipcustomize plugin.
    2. set item core's option "updated scene item" to false.
    3. in play mode try getting to the equip scene.
    all my plugins are updated and in order, i'm only using the plugins mentioned in this post
     
    Last edited: Sep 10, 2017
  14. JLowther

    JLowther Veteran

    Messages:
    311
    Likes Received:
    31
    First Language:
    English
    @Yanfly Sorry to pester again, but I can now finally show you why I'd LOVE to have this addition for picture common events:
    https://forums.rpgmakerweb.com/inde...rious-squid-interactive-childrens-book.83827/

    It would help tremendously for any situation where there might be layers of picture common events happening on top of each other, which would be a godsend for minigames and whatnot like what I've shown here.
     
  15. Tatsumaro

    Tatsumaro Veteran

    Messages:
    172
    Likes Received:
    34
    First Language:
    Portugues
    Primarily Uses:
    RMMV
    this is steal a bug??!!!???? why support a BUGD Battle System and left it like this?
     
    kokuromi likes this.
  16. Dimensional13

    Dimensional13 Villager

    Messages:
    6
    Likes Received:
    2
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    Less of a bug but more of an error. the Event Chase Stealth Plugin. The parameters for the gauge are not grouped underneath the Gauge options but rather under the stealth regions option
     

    Attached Files:

  17. EFizzle

    EFizzle Rum aficionado

    Messages:
    294
    Likes Received:
    60
    Location:
    Richmond
    First Language:
    English
    Primarily Uses:
    N/A
    Hey, I want to be able to use "Action Times+" Trait with the STB battle system and I can't seem to find a work-around. One v. Four is never a fair fight and bosses should fight the protagonists on even terms! Is there a way to get that working while also using the STB battle system? I just want the enemy to be able to do a couple different actions during their turn.
     
  18. Kilitar

    Kilitar Veteran

    Messages:
    127
    Likes Received:
    31
    First Language:
    czech
    Primarily Uses:
    RMMV
    Had same problem, after few experiments I reworked turn system completelly - to allow various speed for each action.

    I decided to cut "game turn" into segments.
    In my system single "game turn" is segmented into 12 turn segments = "miniturns". This way I can decide how long it takes when battler takes action.
    For example - fast attck by dagger - 2 segments, normal attack with sword 5 segments, slow attack by crossbow 10 segments. (same for spells, etc..).

    1 segment is 1 "hardcoded" game turn by STB battle system.
    So in fact, if attacker uses 5 segments long sword attack - he attacks in 1st turn- and then gets 4 turns "cant move - but no penalty" state - to skip next 4 segments = hardcoded game turns. Next action he can take in segment 5 and decide to use slow spell with 10 segments speed. So third action he takes in segment 5+10 = 15. Which in fact is my game turn 2 - segment 3.
    (but in STB system it is in fact turn 15)

    (basically my speed table is : 0 segment action = instant, 1-3 fast speed actions, 4-6 medium speed actions, 7-9 - slow speed actions, 10-12 very slow speed actions.)
     
    Last edited: Sep 17, 2017
  19. ChampX

    ChampX Veteran

    Messages:
    115
    Likes Received:
    57
    First Language:
    English
    Hello Yanfly, I just wanted to point out a possible oversight in your updated KeyboardConfig as I get the following:

    /js/plugins/YEP_KeyboardConfig.js:297 Uncaught TypeError: Cannot read property 'States' of undefined

    which brings us to this snippet of code:

    var array = JSON.parse(Yanfly.Parameters['Button Events List'] || '[]');
    Yanfly.Row.States[ i ] = [];
    for (var j = 0; j < array.length; ++j) {
    if (Yanfly.Param.KeyConfigEv.contains(array[j])) continue;
    Yanfly.Param.KeyConfigEv.push(parseInt(array[j]));
    }


    where Yanfly.Row.States = [ i ]; (I spaced so its not BBCode) is the line causing the error. Commenting it out will make everything work as intended and I could not find any other instances of this being used in the plugin either so I am not sure if it is supposed to be there. Maybe it was defined in another one of your plugins that I happen to not be using? I couldn't find it in any of your other plugins that I am currently using either. This problem does not exist in the previous version of KeyboardConfig.

    Just figured I would let you know as other users will probably get the same error as well if Yanfly.Row.States is defined in a plugin they do not have.

    Edit: Yanfly.Row is defined in your Row Formation plugin, which I am not using so any user using Keyboard Config and not Row Formation will encounter this error. The fix would be to check if it's defined first before assigning the empty array if that line is necessary. I should have downloaded a zip of all your plugins before and grep'd for Yanfly.Row to make this easier for you to fix. Sorry about that.
     
    Last edited: Sep 26, 2017
  20. AdamSakuru

    AdamSakuru Veteran

    Messages:
    166
    Likes Received:
    60
    Location:
    Calgary, Alberta.
    First Language:
    English
    [Bug Report]

    Plugin Name:
    YEP Improved Battlebacks.

    Do you have all the latest updates for the plugins in question?
    Yes.

    Plugin Parameter Changes:
    None.

    Bug Explanation:
    If Battle-back 1 is a scrolling battle-back (either horizontal/vertical or both) it will reset to its default position when action sequence tags are used to add new battle-backs. So to explain a bit further: Let's say battle-back 1 is a scrolling sky, and battle-back 2 is a floor graphic. And in an action sequence for a skill, battle-back 3 is added. When the new battle-back is added, battle-back 1 will immediately jump to it's default X and Y. It's a bit jarring visually. Since battle-back 2 covers the first battle-back, it's likely people would want battle-back 1 to be a scrolling sky, etc. so I'm sure others have run into this too.

    Sort of unrelated:
    There's also another visual bug, but I can't seem to re-create this outside of my own project. So I'll try to explain it as best as I can:
    When I had more than 3 battle-backs, after a number of times of battle-backs fading in and fading out through action sequences, the battler sprites would start flickering black when fades were supposed to happen. I'm not sure why this only happens sometimes or when there's a certain number of battlers on the battle screen, but it made it difficult to figure out the exact cause in a fresh project.

    Bug Demo Instructions:
    Open the troop database and start the battle. I set up the battle-backs in a way that reflects my own project. Battleback 2 is the floor, battleback 1 is the background. Use the basic attack skill on the enemy and note how the scrolling sky reverts to its original position when the screen dims (this is adding a 3rd battle-back to give the illusion that the screen is dimming without dimming the characters themselves.) This only happens with battleback 1. battle-back 2 doesn't seem to have this issue, but battle-back 2 covers battle-back 1. So if you want to have backgrounds that scroll, battle-back 1 seems to be ideal for it.

    Demo Link:

    https://www.mediafire.com/file/4988d4dfu7oetev/Improved Battleback Bug.zip
     
    Last edited: Sep 25, 2017
Thread Status:
Not open for further replies.

Share This Page