RMMV YEP_PartySystem Formation - Faces not appearing when moving.

RK DracoRoy

Fire Emblem RPG Gamer
Veteran
Joined
Jun 29, 2017
Messages
297
Reaction score
93
First Language
English
Primarily Uses
RMMV
MV Version: RPG Maker MV 1.6.2

Plugins used
--------------
YEP_BattleEngineCore*: Battle Engine Core (YEP) - Yanfly.moe Wiki
YEP_PartySystem: Party System (YEP) - Yanfly.moe Wiki

* - Required for Party System's In-Battle Formation command.

Details
--------
The problem here is Yanfly's Formation window and considering the amount of actors I use, when I go about scrolling up or down to get to other actors, an actor's face seems to not be drawn on the window.

Glitch.PNG

At first, the faces are there as I move but then comes the part where one face isn't drawn as I go, then it gets to the point where no actor faces are drawn at all unless I were to move the opposite way for faces to be shown but if I go down to go to a certain actor, same thing, no face is drawn.

What I seem to have found is that if the actors are under different TV spritesheets, this problem happens as I move up / down to get to a certain actor. But if all of them share the same TV spritesheet, this doesn't happen for some reason. But I don't understand why is that.

The photo is only a test version that is showcasing this issue. It bothers me that this is happening, by not drawing the faces quickly at some point as I'm trying to reach a certain actor on the list. Strange thing is this doesn't seem to happen when outside of battle.

I have this test demo project also providing the important steps on a notepad document: https://mega.nz/file/BZwUDKJa#xwsF4ehc8F4D8vbnBRiacp938QKaLSfFiBDXd-vcUyc
 

RK DracoRoy

Fire Emblem RPG Gamer
Veteran
Joined
Jun 29, 2017
Messages
297
Reaction score
93
First Language
English
Primarily Uses
RMMV

Jeremiah Eastman

Gladiator
Veteran
Joined
Apr 24, 2017
Messages
525
Reaction score
323
First Language
English
Primarily Uses
RMMV
Hey there, so I had this happening in my game. I was able to get rid of it but that was a while ago and so much has happened since I am not really sure how I fixed it.

There is a performance plugin I added that I think is what fixed it but I can't be sure. I'll link the plugin incase you want to try it out. One of the things the plugin does is optimize going into the main menu, I'm thinking that is what fixed it. Sorry I couldn't be more helpful, hopefully this fixes it.

Link
https://atelieririna.itch.io/performance-upgrade

Hope you get it worked out.=)
 
Last edited:

RK DracoRoy

Fire Emblem RPG Gamer
Veteran
Joined
Jun 29, 2017
Messages
297
Reaction score
93
First Language
English
Primarily Uses
RMMV
Unfortunately, it's still doing that in my game. I thank you though!
 

Latest Threads

Latest Profile Posts

I haven't been on here in forever wow(missed my forum birthday T-T). Anyways, I'm dabbling in BGMs, here's something I'm actually willing to share.

Binge-watched 6 episodes of the Erased anime... And that means I've watched half of it?! Sigh...
I'm bad at base-building games (looking at other players created an aesthetically beautiful base compared to me), but IDK why I keep playing the game and seek more of it.
Pyra and Mythra in smash ultimate are way too OP. They're basically Smash 4 Bayonetta 2.0, and not in a good way. Very toxic and unfair. At least they're hot tho.
attack on titan keep reaching a new height with each episode, aaa I can't wait another week for a new episode at this point

Forum statistics

Threads
109,197
Messages
1,042,961
Members
141,698
Latest member
ZetabrandX
Top