Yep_X_AnimatedSVEnemies Undefined Bug

Discussion in 'RPG Maker MV' started by xXAinSophAurXx, Jun 8, 2018.

  1. xXAinSophAurXx

    xXAinSophAurXx Veteran Veteran

    Messages:
    37
    Likes Received:
    14
    First Language:
    English
    So I've been using the Yanfly animated SV Enemies plugin for a while without issue, but suddenly after I did some reworking of the plugins in my game and a considerable amount of work on it overall, I had a bug. I was playtesting my game after a while of working on it and in one of the first battles in the game the player fights enemies that are SV Battler sprites, like the player himself.
    Everything goes fine until the enemy uses ANY skill of any kind, the game immediately crashes with a "TypeError undefined is not a function" message. I have no idea what is causing this suddenly. I have added a good few plugins since but turning them on/off doesn't seem to fix the issue, and I am positive I have the most up-to-date versions of my plugins. The error is only removed by turning off the YEP_X_AnimatedSVEnemies plugin. Anyone encounter this issue before?
     

    Attached Files:

    #1
  2. xXAinSophAurXx

    xXAinSophAurXx Veteran Veteran

    Messages:
    37
    Likes Received:
    14
    First Language:
    English
    Ok so after I looked around a bit on here I realized I should check the console when the bug occurs and I found that, for whatever bizarre reason, its the Rune Skills plugin by mjshi that is causing the issue. I have no idea why, because the enemy is just using a normal attack, but disabling Rune Skills makes it work fine. If I can't figure it out, I just might have to scrap Rune Skills. I've attached the console in case anyone is curious or has an idea of why these two plugins might interfere with each other.
     

    Attached Files:

    #2
  3. Andar

    Andar Veteran Veteran

    Messages:
    28,004
    Likes Received:
    6,328
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    1) any change in the plugin order or adding or deactivating a plugin almost always requires to start a new game, because the savefiles contain the old plugin structure.
    Loading an incompatible savefile because of this will result in "undefined" errors as soon as the problematic data is accessed, even if that has nothing to do with what's currently done by the player.

    so does this error happens after a new game or after loading a saved game?

    2) Some plugins require a specific order to function correctly, depending on which functions they override and which functions they append.
    If some of your (unspecified) changes were on the plugin order, that could also cause the problems.

    3) in case of your error log, you should solve the problem of the unexpected token first.
    For some reason the notetag is not correctly identified and the engine believes the closing tag to be part of the code.
    Such an error can cause any other problem because it might mess with other code as well.
     
    #3
  4. xXAinSophAurXx

    xXAinSophAurXx Veteran Veteran

    Messages:
    37
    Likes Received:
    14
    First Language:
    English
    1) Yes on fresh new games it still has the same error
    2) I've tried changing the order around and so far no luck but I will keep trying different orders.
    3) I saw that but wasn't sure how to fix it. i tried turning off the Auto Passive States plugin since that seems to be where the token is coming from but it didn't do anything. I'm actually not sure why I even have Auto Passive States on to be honest, I don't think I'm currently using it.
     
    #4
  5. mjshi

    mjshi Jack of Most Trades Veteran

    Messages:
    874
    Likes Received:
    701
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    N/A
    @xXAinSophAurXx I've received your message, thought it might be best to discuss this issue on this thread since you've started one. I agree, it's really weird that these two would be in conflict. Could you PM a barebones demo with the two plugins? Use https://www.file.io/ or something similar-- I'm currently unable to access Dropbox at the moment. Then I'll take a look for you and I should be able to resolve it within the week.
     
    #5
  6. Aloe Guvner

    Aloe Guvner Walrus Veteran

    Messages:
    1,456
    Likes Received:
    930
    Location:
    USA
    First Language:
    English
    Primarily Uses:
    RMMV
    For your auto passive states errors, you are closing the formula with:
    </Customer Parameters>

    instead of:

    </Custom Parameters>
     
    #6
    xXAinSophAurXx likes this.
  7. xXAinSophAurXx

    xXAinSophAurXx Veteran Veteran

    Messages:
    37
    Likes Received:
    14
    First Language:
    English
    So regarding this error, I have no idea how to fix that. I do not recall ever writing in that "customer parameters" thing anywhere, and I disabled Auto Passive States to see if it would go away, but then the exact same unresolved token comes up but this time referring to Weapon Unleash. I legitimately have no idea how to fix this and I know nothing about coding so if this is an issue in a different plugin then I am totally confused.
     
    #7
  8. Andar

    Andar Veteran Veteran

    Messages:
    28,004
    Likes Received:
    6,328
    Location:
    Germany
    First Language:
    German
    Primarily Uses:
    RMMV
    3) you are using it somewhere
    Just because you did not recall that doesn't mean that it's not in your project.
    Somewhere the plugin found that wrong notetag, and now you'll have to check every entry in your database until you find it and change it to the correct setting.
     
    #8
    xXAinSophAurXx likes this.
  9. xXAinSophAurXx

    xXAinSophAurXx Veteran Veteran

    Messages:
    37
    Likes Received:
    14
    First Language:
    English
    Thank god for the "Find" function, I searched through every single thing in my project and low and behold its an accessory I never even implemented in my game! Found it and fixed it! I am nearly crying from joy, i have been having some lag issues when testing my game because of that token and I never knew that was the cause, now my game is running so smoothly!!
     
    #9
  10. xXAinSophAurXx

    xXAinSophAurXx Veteran Veteran

    Messages:
    37
    Likes Received:
    14
    First Language:
    English
    Thanks to Mjshi for figuring out the Rune Skills/AnimatedSVEnemies conflict, my issue is now SOLVED! Thank you everyone who replied here and helped me clean up my game :D
     
    #10

Share This Page