RMMV YR_ItemCrafting Error

Frostorm

[]D[][]V[][]D aka "Staf00"
Veteran
Joined
Feb 22, 2016
Messages
1,499
Reaction score
1,093
First Language
English
Primarily Uses
RMMV
So I just tried using this plugin but I get this error when trying to run the plugin command "CRAFT START Stuff" ("Stuff" is the name of the discipline in the plugin options). I also tried this w/ & w/o a background img in the plugin settings, but same result either way.
1603888850092.png
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,246
Reaction score
7,627
First Language
German
Primarily Uses
RMMV
most important question:
have you tried that with a new playtest or did you load an older savegame?

that "undefined" in the error basically means that the plugin tried to acces something that doesn't exist.

and that can only happen in three ways:
1) you continued an older savefile from before that plugin was added - that means the gamedata is missing the new plugin.
2) the plugin has been configured wrong - like having receipes for items that do not exist in the database
3) incompatibility between this and another plugin.
 

Frostorm

[]D[][]V[][]D aka "Staf00"
Veteran
Joined
Feb 22, 2016
Messages
1,499
Reaction score
1,093
First Language
English
Primarily Uses
RMMV
most important question:
have you tried that with a new playtest or did you load an older savegame?

that "undefined" in the error basically means that the plugin tried to acces something that doesn't exist.

and that can only happen in three ways:
1) you continued an older savefile from before that plugin was added - that means the gamedata is missing the new plugin.
2) the plugin has been configured wrong - like having receipes for items that do not exist in the database
3) incompatibility between this and another plugin.
Ok, I tried it in a brand new project. Nothing in the settings changed (all default). The only plugins installed are YEP_CoreEngine, YEP_ItemCore, & YR_ItemCrafting. Same error.

SameError.png

This plugin is advertised to work w/ YEP_ItemCore's independent items (which is why I chose this plugin) so I don't see why there'd be compatibility issues w/ YEP_ItemCore...
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,246
Reaction score
7,627
First Language
German
Primarily Uses
RMMV
Ok, I tried it in a brand new project.
I didn't ask for a new project, I asked for a new playtest. You know, at the playtest titlescreen where you can select between "new game", "continue" and "options".

But it doesn't matter anymore - a new project would be the same, and you already told me where your mistake is above:
Nothing in the settings changed (all default).
While there are a few cases where defaults may work, that is almost impossible in a crafting plugin.

You HAVE TO CONFIGURE the plugin, because the defaults will almost never fit your specific database.
How do you expect crafting to work with items that are unknown to the plugin?
 

Frostorm

[]D[][]V[][]D aka "Staf00"
Veteran
Joined
Feb 22, 2016
Messages
1,499
Reaction score
1,093
First Language
English
Primarily Uses
RMMV
How do you expect crafting to work with items that are unknown to the plugin?
Well, I was expecting at least to get to the crafting menu with blank/empty entries... It seems like the error pertains to something related to a background img, so it didn't cross my mind that would have anything to do w/ the items/recipes.

Basically, I just wanted to check out the UI layout before I started to tinker/customize it. (I'm kinda window shopping per se)

Edit: So I just found the info to put in the main menu manager so the Crafting button shows up. I get a similar error when I press it though. What do I have to do to get started/setup?
 
Last edited:

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,246
Reaction score
7,627
First Language
German
Primarily Uses
RMMV
I don't know because you never gave a link to the website of the plugin.

but best guess? the plugin expects you to tell it in its configuration which picture to use for the background. Something that can't be set by default because the image depends on your available pictures - or did the programmer provide a picture that you failed to copy?
 

Frostorm

[]D[][]V[][]D aka "Staf00"
Veteran
Joined
Feb 22, 2016
Messages
1,499
Reaction score
1,093
First Language
English
Primarily Uses
RMMV
I don't know because you never gave a link to the website of the plugin.

but best guess? the plugin expects you to tell it in its configuration which picture to use for the background. Something that can't be set by default because the image depends on your available pictures - or did the programmer provide a picture that you failed to copy?
There is no website, there is a direct link to the plugin file from @YoraeRasante's plugin thread (for various plugins). I've already tried both setting an img in the plugin options for the bg, but I still get the same error...
1603912508330.png
 

Andar

Veteran
Veteran
Joined
Mar 5, 2013
Messages
31,246
Reaction score
7,627
First Language
German
Primarily Uses
RMMV
I've already tried both setting an img in the plugin options for the bg, but I still get the same error...
then you have done something wrong when using that setting, because as I already told you, that error means that there is no correct data in that configuration.
and if the setting you tried got you the same error, then that means that the data was still wrong, and you have to look for the correct entry into that configuration.

and please READ what is written in the topic you linked. That plugin was made to be similar to another plugin with only some changes, so you need to search for the website of that other plugin to get better descriptions of what to do if the plugin help itself is not enough.

but no matter what, to get the plugin working you need to find the correct data for exactly that setting and everything that is involved with it - the plugin CANNOT work in default settings, exactly as I assumed above.
 

Frostorm

[]D[][]V[][]D aka "Staf00"
Veteran
Joined
Feb 22, 2016
Messages
1,499
Reaction score
1,093
First Language
English
Primarily Uses
RMMV
That plugin was made to be similar to another plugin with only some changes, so you need to search for the website of that other plugin to get better descriptions of what to do if the plugin help itself is not enough.
That's the thing though, I've tried the plugin this one is based on (MrTrivel's crafting plugin) and had no problems using it right out of the box w/ no changes whatsoever... That's why I'm so confused, I don't know how to get this plugin set up correctly. I've read both the help file and the plugin thread btw.

Edit: I did get the main menu button for this crafting plugin working though. Turns out I had to put it ABOVE YEP_ItemCore instead of below (I hope this is correct). The plugin's help section made no mention of plugin ordering btw. However, the plugin commands still throw that same error from earlier.
Sprite-0019.png
1603926190501.png
Also, since I moved the plugin order of this plugin above YEP_ItemCore, does this mean independent items will or won't work?

Edit2: I finally got the bug to go away! Turns out the plugin's help section is wrong. The example given is "CRAFT START Craft" when in reality it should be "CRAFT START 1", as in a number (ID) needs to be used instead of the string for the discipline name. Again, this is in contradiction to the help section.

Anyways, I was right to assume the plugin didn't need to be configured (default settings are fine), just like other crafting plugins. My 1st course of action when checking out a crafting plugin is to look at the UI before implementing items/recipes. I'm just glad I was able to do so here as well.
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Latest Threads

Latest Posts

Latest Profile Posts

Just finished composing a boss battle theme!
Scripted a multi-variable weather system that randomizes wind speed, cloudiness, rain, fogginess, etc, while attempting to realistically account for interactions between them (e.g. wind speed affects fogginess, cloudiness affects rain, etc), the current weather pattern, and the player's biome e.g. swamp, beach, etc. Now I "just" have to tie visuals and sounds to the variables so stuff actually happens...
I'm having a headache balancing the combat using flat defense so I'm gonna use percentual armor, in this pic, Simon has 16 on Defense which means all the incoming damage will be reduced by 16% this will ease my burden a bit.
!Have a nice day everybody¡
SO glad they patched outer worlds for switch! I can finally play it! Weird that other peeps are still having issues. I know it was really chugging on my lite when it first came out.

Forum statistics

Threads
105,555
Messages
1,014,620
Members
137,231
Latest member
anjing_gila
Top